SSLVPN Portal Customization Language Selector

Unanswered Question
Nov 12th, 2008

Hi, I'm trying to use the "full customization" feature in the ssl/webvpn on ASA.

Running version 8.0(4).

I can customize the page, and get the login dialog to display correctly.

However, I am unable to get the Language Selector drop down combo box to display when I use the full customization feature.

I've tried to follow the direction on http://www.ciscosystems.com/en/US/docs/security/asa/asa80/asdm60/selected_topics/adv_custom.html, but even though it is in the code, even the demo page there does not show the language selector.

The language selector is set to "enable" in the customization.

Any suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Loading.
smahbub Tue, 11/18/2008 - 15:17

With full customization, you can provide HTML for your own login screen, and then insert Cisco HTML code that calls functions on the security appliance that create the Login form and the Language Selector drop-down list.Language Selector drop-down list is present under the tab customization editor.

for more information on language selector(refer figure 5):

http://www.ciscosystems.com/en/US/docs/security/asa/asa80/asdm60/selected_topics/adv_custom.html#wp1007576

Jonatan Jonasson Mon, 11/24/2008 - 14:53

Issue resolved:

(After assistance from TAC)

The problem is that the selector needs to be loaded before the form (lform).

In the example html code used in the url I referred to in my previous post, the form is loaded before the selector.

That is, the following code:

" "

needed to be changed to:

" "

Swapped the selector and the login form, so that the selector loads first, and then the form.

This resolved the case for me on two different ASA boxes (5510 and 5520, both running 8.0(4). )

Actions

This Discussion