806 IOS download via xmodem problem

Unanswered Question
Nov 13th, 2008

Hi all,


I've got a 806 router with two problems :


ROMmon corrupt and a bad IOS for the hardware.


I've resolved the first problem (ROMmon corrupt). I've download by xmodem a new one by the command xmodem -u.

Then, i'm trying to download now a good IOS image by xmodem too with the command "xmodem c806-o3sy6-mz.123-14.T7.bin" with Tera Term. When my router say :"Do not start the sending program yet...

device does not contain a valid magic number

dir: cannot open device "flash:

WARNING: All existing data in bootflash will be lost!

Invoke this application only for disaster recovery.

Do you wish to continue? y/n [n]: y

Ready to receive file c806-o3sy6-mz.123-14.T7.bin" I launch the upload with TeraTerm by : File|transfer|XMODEM|send.

The control panel stay at : Packet# : 128

Bytes transfered :0% and one minute later there is a time out. I don't understand wy the ROMmon image download worked and not for the IOS. Could you help me please.


Thank you by advance.


Pierrick


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 11/13/2008 - 05:11

Hello Pierrick,

try to use

ROMMON tftpdnld command


as explained in another thread, once you have a working rommon you can do in this way


Hope to help

Giuseppe


pibuskowa Thu, 11/13/2008 - 06:27

Hello Giuseppe,


The tftpdnld is working but i've got this message at the end of the download :


File reception completed.

TFTP flash copy: Invalid file header, copy terminated.

Reason: Wrong target platform OR corrupt file.


I don't understand because it's the good IOS, it's an IOS taken in an another 806...


Any idea ?

Giuseppe Larosa Thu, 11/13/2008 - 09:35

Hello Pierrick,

it looks like your router thinks to be something else or you need to format the flash before trying to write over it.


I would try to format the flash from rommon


Hope to help

Giuseppe


pibuskowa Thu, 11/13/2008 - 09:59

Giuseppe,


How to format flash in rommon?


Normally, when you download an IOS from ftpdnld, the flash is formatted, no?


I've got the same error...

Actions

This Discussion