QOS Configuration not working...

Unanswered Question
Nov 13th, 2008
User Badges:

Hello,


I have Snom phones that do SIP / RTP and connect to an Asterisk server.


The following configuration I have tried does not seem helpful..please help!


#Access-list with Snom SIP & RTP

ip access-list extended voip-traff

permit udp any any range 5060 5061

permit udp any any range 10000 20000


#class-map named ipphone & match acl voip-traff:

class-map match-any ipphone

match access-group name voip-traff


#Policy map named voip, match class-map iphone:

policy-map voip

class ipphone

set dscp cs5


#set interfaces to police policy-map voip:

interface-range gi 0/1 - 48

service-policy input voip


#enable qos globally:

mls qos


#map out QOS to COS-DSCP


#or mls qos map cos-dscp 0 8 16 24 32 40 46 48


Please help!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anonymous (not verified) Wed, 11/19/2008 - 09:12
User Badges:

Are the VOIP phones currently sending at a certain DSCP value?

How are you verifying that the DSCP values aren't being set properly?

Can you send a "show policy-map int " on an interface that is positively getting and receiving traffic?


jamesfang98 Wed, 11/19/2008 - 12:20
User Badges:

how about this:


ip access-list extended voip-traffic

permit udp any any range 5060 5061 <-SIP

permit udp any any range 16384 32767 <-RTP


class-map match-all class_ipphone

match access-group name voip-traffic


policy-map pol_voice

class class_ipphone

set dscp ef

class class-default

set descp 0


int-range gi0/1 - 48

service-policy input pol_voice


mls qos

mls qos map cos-dscp 0 8 16 24 32 46 48 56


This way, it will identify all RTP/SIP traffic from such interface which phones connected, then assign them with appropriate dscp value, inside switch itself, it will use internal CoS-DSCP map to adjust 'CoS-5' to 'DSCP-46' for all following traffics flow.


Also run:


show policy-map int gi0/1 input


to see marking result


Please rate if help


James



Actions

This Discussion