Custom WebAuth issues

Unanswered Question
Nov 13th, 2008

I'm trying to get a custom webauthentication page for two WLANs working, with RADIUS authentication.


The default web-auth page has been operational for some time so there are no issues with the process itself.


For some reason when I click on the submit button, while using the custom page, nothing happens. There's no redirect, no entry in RADIUS.


The script code is exactly the same, word for word. The only things modified are the style layouts of the page as well as the coloring.


I've noticed this line of code for the scripting:


"<script language="javascript" src="./loginscript.js"></script>"


Is 'loginscript.js' something that needs to be set up and uploaded along with the custom page, or is that coded into the WLC software?


Any other insight on why this may not be working? Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
amritpatek Wed, 11/19/2008 - 09:53

In 4.1, the feature to allow upload of webauth html files to the controller was introduced. Only when the webauth type is "customized" (not external or internal), the webauth URL includes "fs/customwebauth" to point to the files stored on the controller's flash file system. This should not affect scripts that were used before, for internal or

external webauth.


You can navigate the directories for web related html files (only the uploaded ones) using devshell shell. You will be able to find the custom webauthentication directory, after you have uploaded the webauth files to the controller.

Scott Fella Thu, 11/20/2008 - 05:30

For kicks, load the same webauth page and see if that works.... seems like when you were customizing the page you removed some of the html codes.

jpeterson6 Thu, 11/20/2008 - 07:33

I just tried uploading the original auth page as a custom.


What happens is interesting- the Submit button disappears.


I copied the javascript.js and added it to the TAR archive for the new page. The button appears but the script doesn't seem to run properly. This may have pointed me in the right direction though.. may very well just be missing some code afterall.

Actions

This Discussion

 

 

Trending Topics - Security & Network