ACS UCP Issue

Answered Question
Nov 13th, 2008
User Badges:

I have ACS , IIS & UCP installed on same Windows 2003 server. UCP was installed recently. IIS configuration was done before UCP installation.


After installation I tried to access UCP via the URL http://localhost/secure/login.htm

I get the login prompt. When i enter username and password, i am getting "page cannot be displayed" webpage. Please let me know resolution for the same.

Correct Answer by cisco24x7 about 8 years 7 months ago

1- done

2- done

3- done

4- done

5- done

6- done

7- done

8- done

9- reboot the windows 2003 server

10- from the ACS server itself, launch https://server/secure/login.htm


11- The Cisco Secure ACS UCP Application shows up:

12- Enter a user ACS useraname and password:


It says:


The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.


HTTP Error 404 - File or directory not found.

Internet Information Services (IIS)


Anymore ideas? Thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
cisco24x7 Fri, 11/14/2008 - 12:39
User Badges:
  • Silver, 250 points or more

I am running into the same situation.


I have windows 2003 running ACS version 4.0.1.

The ISS server is running and serving web page.

ACS 4.0.1 and IIS run on the same server


I followed the instructions steps-by-steps in

the release notes. When I type https://server/secure/login.htm, I can see the

UCP page. However, after I type in the username

and password, I got this link:


The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

--------------------------------------------------------------------------------


Please try the following:


Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.

If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.

Click the Back button to try another link.

HTTP Error 404 - File or directory not found.

Internet Information Services (IIS)


I make everything under c:\inetpub\wwwroot\

FULL control to EVERYONE. I am at a lost here

can someone help? The link provided above did

not work for me either. The windows 2003

is a stand-alone box.


Thanks.

Jagdeep Gambhir Fri, 11/14/2008 - 12:54
User Badges:
  • Red, 2250 points or more

Did you allow unknown cgi ? That is

step 5 in the attached PDF. I was getting a 404 error until I enabled this.


If the web server runs IIS 6.0, you must configure IIS to allow unknown CGI

extensions. To do so, use the Web Service Extension page in the IIS Manager

window and set the status of Allow Unknown CGI Extensions to "Allowed".



Regards,

~JG


Do rate helpful posts




Attachment: 
cisco24x7 Fri, 11/14/2008 - 13:04
User Badges:
  • Silver, 250 points or more

Ofcourse, I allow unknown cgi. I've gone

through the configuration lines by lines.


Need to get this working ASAP in the lab so that

I can tell the vendor that I need this feature

to change password periodically.

Jagdeep Gambhir Fri, 11/14/2008 - 13:45
User Badges:
  • Red, 2250 points or more

Also server require more privileges for the internal windows user that runs CSusercgi.exe.


The name of the windows user that runs UCP is IUSR_.


Workaround steps:


1) Install UCP 4 on a machine that runs IIS server.


2) Open IIS manager


3) Locate Default Web Site


4) Double click on the virtual name 'securecgi-bin'


5) Right click on CSusercgi.exe and choose Properties


6) Choose 'File Security' tab


7) Choose 'Edit' in 'Authentication and access control' area


8) Change username from IUSR_ to 'Administrator' and enter his

password (make sure that 'Integrated Windows authentication' is checked)


Now please check UCP from a user browser, and see that you get the second screen instead

of 'CGI error'.


Regards,

~JG


Correct Answer
cisco24x7 Fri, 11/14/2008 - 13:58
User Badges:
  • Silver, 250 points or more

1- done

2- done

3- done

4- done

5- done

6- done

7- done

8- done

9- reboot the windows 2003 server

10- from the ACS server itself, launch https://server/secure/login.htm


11- The Cisco Secure ACS UCP Application shows up:

12- Enter a user ACS useraname and password:


It says:


The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.


HTTP Error 404 - File or directory not found.

Internet Information Services (IIS)


Anymore ideas? Thanks.


aneesh.ts Wed, 11/19/2008 - 01:47
User Badges:

It worked for me finally. I uninstalled and reinstalled UCP. Something different i did was assing login.htm in default webpage properties and moving it up the order. I found a patch in microsoft site for http error 405 which i was getting.


Like it always happens with windows, a restart along with the reinstallation and the changes fixed my issue.

Actions

This Discussion