Routing between Token Ring and Ethernet

Unanswered Question
Nov 14th, 2008
User Badges:

Hello Experts,


I have a Cisco 3825 (revision 1.2) with 225280K/36864K bytes of memory running "flash:c3825-spservicesk9-mz.124-3g.bin".


There are VLANs configured on the router and each port on its respective VLAN connects to its own Layer 2 switch.


I am trying to get the routing between a token ring PC and one of the ethernet PCs.


Both the PCs are able to ping their Default gateways. Token ring PC is able to ping the Ethernet Interface address but not the PC on the VLAN.


I would greatly appreciate if one of you could please help me out here.


Config below -


Building configuration...


Current configuration : 2212 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname RouterA

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

ip subnet-zero

ip cef

!

!

!

!

voice-card 0

no dspfarm

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 2.33.209.5 255.255.255.255

!

interface GigabitEthernet0/0

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

negotiation auto

!

interface FastEthernet0/1/0

description ** Server Subnet **

switchport access vlan 2

!

interface FastEthernet0/1/1

description ** Token Ring **

switchport access vlan 3

!

interface FastEthernet0/1/2

!

interface FastEthernet0/1/3

description Core-Switch

switchport access vlan 4

!

interface Serial0/0/0

ip address 2.33.236.17 255.255.255.252

encapsulation frame-relay

!

interface FastEthernet1/0

no ip address

shutdown

duplex auto

speed auto

!

interface TokenRing1/0

ip address 172.25.148.1 255.255.252.0

ring-speed 16

!

interface Vlan1

no ip address

!

interface Vlan2

description ** Server Subnet **

ip address 172.25.232.3 255.255.252.0

standby 2 ip 172.25.232.1

standby 2 timers msec 500 1

standby 2 priority 110

standby 2 preempt

!

interface Vlan3

description ** Firewall **

ip address 172.25.236.3 255.255.255.0

standby 3 ip 172.25.236.1

standby 3 timers msec 500 1

standby 3 priority 110

standby 3 preempt

!

interface Vlan4

desc Core-Switch

ip address 172.25.238.3 255.255.255.0

standby 4 ip 172.25.238.1

standby 4 timers msec 500 1

standby 4 priority 110

standby 4 preempt

!

router bgp 65012

no synchronization

bgp log-neighbor-changes

timers bgp 10 30

redistribute connected

neighbor 2.33.236.18 remote-as 5462

neighbor 2.33.236.18 soft-reconfiguration inbound

no auto-summary

!

ip classless

!

!

ip http server

no ip http secure-server

!

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

line con 0

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password cisco

login

!

scheduler allocate 20000 1000

!

end



Many thanks,

Arav

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Fri, 11/14/2008 - 05:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Arav


You tell us that: "Token ring PC is able to ping the Ethernet Interface address". Can you also do that same type of test for the Ethernet PC, can the Ethernet PC ping the Token Ring interface address?


HTH


Rick

aravindhs Fri, 11/14/2008 - 06:35
User Badges:

Thank you very much for your reply, Rick.


The customer has replied with the following -

---------

none of the Ethernet subnets can ping the token ring subnet, however the token ring subnet can ping all of the ethernet subnets!


One other thing I noticed was that even though I could ping the gateway address of all the Ethernet subnets (232.1, 236.1 & 238.1) from the token ring subnet, I couldn't ping the PC address (232.50 for example).


-----------


So, I have requested for a more detailed explanation of this. Once i get a response, I shall post it back here. Looking forward to your help here.


Kind Regards

arav

aravindhs Fri, 11/14/2008 - 07:09
User Badges:

Hi Rick,


These are the results -


Pinging from the Token Ring PC, I can ping the Ethernet gateways, just not the PC connected to any of them.


Pinging from the Ethernet PC, I can't ping the Token Ring interface.


Harold Ritter Fri, 11/14/2008 - 07:14
User Badges:
  • Cisco Employee,

Arav,


Is there a default gateway configured on the Ethernet connected PC?


Regards

aravindhs Fri, 11/14/2008 - 07:23
User Badges:

Hi Harold,


The default gateways are configured on the PC and the customer has confirmed that it is correct.


I have never done TokenRing before nor could I find any relevant documents to sort this out.


Many thanks for all your help. Looking forward to your help to get this working.


Many thanks

Arav

Richard Burts Fri, 11/14/2008 - 10:27
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Arav


One of the nice things about routing IP at layer 3 is that IP is not dependent on any layer 2 things (which is where Token Ring and Ethernet are different). So from an IP routing standpoint it no different routing to Token Ring or routing to Ethernet.


The symptoms suggest that either the default gateway on the Ethernet is not really correct or that there is some kind of access list or other filtering that is preventing the traffic. I would suggest that you ask that they provide the output of ipconfig (or other appropriate command if the device is not Windows) from both the Ethernet PC and the Token Ring PC.


HTH


Rick

aravindhs Wed, 11/19/2008 - 09:01
User Badges:

Hi Rick


Please find the outputs of the ipconfig screen and some debug and show arp outputs from the router.


Many thanks


Regards

Arav



Attachment: 
Richard Burts Wed, 11/19/2008 - 11:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Arav


Thank you for the additional information. It does show that both PCs do seem to have correct default gateways configured, which was one of my theories.


I wonder if the issue might be a firewall on the Ethernet PC at 172.25.232.50. Is it possible that the PC does not accept ping? If you just do a standard ping from the router to the PC does it respond?


HTH


Rick

aravindhs Thu, 11/20/2008 - 01:40
User Badges:

Hi Rick,Many thanks for your quick rply.

Please find some ping outputs sourced from its own interface IP and from each other.


HART-WA01-RH1#ping 172.25.232.50


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.25.232.50, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

HART-WA01-RH1#ping 172.25.148.47


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.25.148.47, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms


HART-WA01-RH1#ping 172.25.148.47 so vl2


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.25.148.47, timeout is 2 seconds:

Packet sent with a source address of 172.25.232.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

HART-WA01-RH1#ping 172.25.232.50 so tok1/0


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.25.232.50, timeout is 2 seconds:

Packet sent with a source address of 172.25.148.1

.....

Success rate is 0 percent (0/5)


interface Vlan2

description ** Server Subnet **

ip address 172.25.232.1 255.255.255.0

end


interface TokenRing1/0

ip address 172.25.148.1 255.255.252.0

ring-speed 16

end


Many thanks, Arav

Richard Burts Thu, 11/20/2008 - 04:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Arav


Thanks for the additional information which I asked for. It certainly shows that it is not an issue with a firewall preventing pings. What happens if you do ping sourced from vlan 3 or from vlan 4?


I also wonder if you could post the output of route print from the Ethernet PC.


HTH


Rick

aravindhs Fri, 01/02/2009 - 02:34
User Badges:

Hi Rick


Happy new year to you and everyone from our forum !Apologies for the late reply ! But the problem is fixed ! Thanks for all your help. Please find the config -

Source-Route Translational Bridging (SR/TLB))

!

source-bridge ring-group 10

source-bridge transparent 10 11 1 1

!

interface FastEthernet0/1/0

description ** To 232 Subnet **

switchport access vlan 2

!

interface TokenRing1/0

ip address 172.25.148.1 255.255.252.0

ring-speed 16

source-bridge 1 1 10

source-bridge spanning

!

!

interface Vlan2

ip address 172.25.232.3 255.255.255.0

standby 2 ip 172.25.232.1

standby 2 timers msec 500 1

standby 2 priority 110

standby 2 preempt

bridge-group 1

!

bridge 1 protocol dec

bridge 1 bitswap-layer3-addresses


HTH

Arav

Richard Burts Fri, 01/02/2009 - 04:59
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Arav


I am glad that you found a solution for the problem. Thannk you for posting back to this thread and indicating that the problem was solved and how you solved it. It helps make the forum more useful when people can see that a problem has been resolved.


HTH


Rick

Actions

This Discussion