4.13 to 6.12 Migration - dbreplication errors

Unanswered Question

Anyone know what this means and how to resolve.

Ran this on the Pub Server

admin:utils dbreplication status

****************************************************************************************************

This command reads and writes database information from all machines and will take quite some time...please be patient.

****************************************************************************************************

-------------------- utils dbreplication status --------------------

Status cannot be performed when replication is down on the publisher, or on a cluster with a single active node; aborting replication status check operation

Output is in file cm/trace/dbl/sdi/ReplicationStatus.110814.out

admin:

All the required services are started on the PUB and the SUB but replication status shows

0 - Initializing for both servers.

HELP

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jaime Valencia Fri, 11/14/2008 - 10:33

there is a post on the very same page just 3 rows below yours with the same issue, please look at previous posts.

IP Telephony: DBreplication Fail - Replicate_State=0

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&topicID=.ee6c829&fromOutline=&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.2cc259a5

HTH

java

if this helps, please rate

rob.huffman Fri, 11/14/2008 - 10:40

Hi Dave,

The only time I have seen this problem (after an upgrade) on these forums, the problem was solved by re-installing the Sub :)

Hope this helps!

Rob

Tommer Catlin Fri, 11/14/2008 - 10:50

I agree. I had these kind of problems after upgrades and basically after hours and hours on TAC, we reloaded the subscriber... and magically it worked fine then. Takes about an hour to load up the subscriber again right? easy fix.

Take note though, once you do the initial publisher install, do not change ANYTHING on the publisher until the subscriber comes up. That includes IP address, names, anything in the system.

Just Wanted to report back the results of this problem.

Re-installing the subscriber servers DID NOT reslove this issue.

Opened a TAC Case.

Had tac use root access to clean up the following 4 files. /etc/hosts, /etc/services

the sqlhosts and rhosts files too.

After cleaning all four files of miscellaneous information, they did a UTILS DBREPLICATION STOP on each server starting with the 2 subs and then the pub. After this command ran succussfully they did a UTILS DBREPLICATION CLUSTERREST.

This process took 1.5 hours to complete. After this completed they rebooted the pub, waited 15 minutes and then rebooted sub1, waited 15 minutes and rebooted sub2.

Finally, all three servers sync'd up and now show 2 (good) for DB Replication.

Hope this will help someone else in this situation.

Actions

This Discussion