Frame Relay

Unanswered Question
Nov 14th, 2008

Hi Everyone,

I am having trouble with packet tracer 5, I cant create sun-interfaces on serial links

I can do it on Ethernet links no probs just the serial..

Is it supported??

int ser 0/0

encapsulation frame relay ietf

frame relay lmi-type ansi

no ip address

no shut

exit

int ser 0/0.120

%cannot create sub-interface

help please

Shane

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Fri, 11/14/2008 - 20:07

From Frame-Relay subinterface, you need to select either a point-to-point or point-to-multipoint mode.

Just use the online help while typing interface s0/0.120 ?

HTH,

__

Edison.

shane.kearney Sun, 11/16/2008 - 17:30

int ser 0/0

encapsulation frame relay

no ip address

no shut

exit

int ser 0/0.120 point-to-point

%cannot create Frame Relay sub-interface

anybody have any idea what is going on or does packet tracer 5 not support sub-interfaces on serial links

Richard Burts Sun, 11/16/2008 - 18:42

Shane

A detail that I notice is that in both your posts you have indicated in your config:

encapsulation frame relay

which should be:

encapsulation frame-relay

I am not sure whether that is a cosmetic issue (which seems likely given that the error message in this post is clear that it recognizes that it is dealing with Frame Relay (cannot create Frame Relay sub-interface)) or whether the packet tracer really has problems creating Frame Relay subinterfaces. If you correct the syntax and the problem persists then I would be suspicious that it is an issue in packet tracer.

HTH

Rick

ccent2ccna Thu, 02/10/2011 - 05:31

Hey Shane,

I have Packet Tracer and I encountered the same problem. The solution is easy.

Actually, you are able to create a sub-interface on a serial link in Packet Tracer only if the encapsulation type is set to frame-relay.

You must also include the "multipoint" or "point-to-point" parameter when creating the subinterface.


For example:

R1# conf t

R1(config)# interface serial 0/0

R1(config-if)# encapsulation frame-relay

R1(config-if)# interface serial 0/0.123 point-to-point

OR

R1(config-if)# interface serial 0/0.123 multi-point

R1(config-subif)#

Router>en

Router#Conf t

Router(config)#interface serial0/0.102 point-to-point

To create a multipoint subinterface, enter multipoint instead:

Router(config)#interface serial0/0.1 multipoint

Now two things to keep in mind, first you have to put a dot right after the serial interface and specify the sub-interface number (serial0/0.102, serial0/0.103, serial0/0.104, etc...).

Second thing is you HAVE to specify afterward if it is a point-to-point or multipoint.

Here is an example of Frame Relay configuration:

a.         Create and configure subinterface s0/0/0.102. From global configuration mode, enter the following commands:

R1(config)# interface Serial0/0/0.102 point-to-point

R1(config-subif)# ip address 10.0.1.1 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 102

R1(config-subif)# exit

b.         Repeat the above steps to create and configure subinterface s0/0/0.103 and s0/0/0.104.

R1(config)# interface Serial0/0/0.103 point-to-point

R1(config-subif)# ip address 10.0.1.5 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 103

R1(config-subif)# exit

R1(config)# interface Serial0/0/0.104 point-to-point

R1(config-subif)# ip address 10.0.1.9 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 104

R1(config-subif)# exit


Hope that helps.

ilucas312 Wed, 02/16/2011 - 17:32

Some very thorough and helpful posts, but my class cannot even get the frame-relay intf-type dce command to go through. It rejects every time. Sub-interface commands work fine, but the intf-type won't take.

Any help?

Thanks.

Also, why have they not fixed the course information to reflect the info needed?

russellhalfar Fri, 09/13/2013 - 10:52

At this point the original question should be marked "Answered." As other posters here have noted, Packet Tracer 5 does support sub-interfaces so long as the command to create that interface is followed with multipoint or point-to-point.

But the last issue brought up about specifying the frame-relay encapsulation type (ietf vs Cisco) still seems unanswered.

In Packet Tracer it appears that you are able to specify ietf if you want to use RFC1490/RFC2427 encapsulation.


R0(config-if)#encapsulation frame-relay ?

  ietf  Use RFC1490/RFC2427 encapsulation

 

Am I right to assume that taking the default selects cisco encapsulation as opposed to ietf? If that's the case it seems that specifying ietf has no effect in Packet Tracer. The next two outputs demonstrate how specifying ietf does not "stick."

R0(config-if)#encapsulation frame-relay ietf

R0(config-if)#do show int s0/0

Serial0/0 is up, line protocol is up (connected)

  Hardware is HD64570

  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation Frame Relay, loopback not set, keepalive set (10 sec)

R0(config-if)#encapsulation frame-relay

R0(config-if)#do show int s0/0

Serial0/0 is up, line protocol is up (connected)

  Hardware is HD64570

  MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

Encapsulation Frame Relay, loopback not set, keepalive set (10 sec)

I need to get to some live equipment!!!

Actions

This Discussion