not able to connect smart card reader in WS-X4648-RJ45V-E

Unanswered Question
Nov 15th, 2008

we have installed one Ws-4507R-E switch and it is having 4 nos of WS-X4648-RJ45V-E module. When we tried to connect one smart card reader to any of the ports in these modules it is showing not connecetd in the interface status. At the same time if we connecte the same device to 3560 switch it will work !! following atre the sh module output of 4507 switch.

sh module all

Chassis Type : WS-C4507R-E

Power consumed by backplane : 40 Watts

Mod Ports Card Type Model Serial No.

---+-----+--------------------------------------+------------------+-----------

1 48 10/100/1000BaseT POE E Series WS-X4648-RJ45V-E JAE1234SPB6

2 48 10/100/1000BaseT POE E Series WS-X4648-RJ45V-E JAE1238UYDC

3 6 Sup 6-E 10GE (X2), 1000BaseX (SFP) WS-X45-SUP6-E JAE1236TQQY

4 6 Sup 6-E 10GE (X2), 1000BaseX (SFP) WS-X45-SUP6-E JAE1235TEYJ

5 48 10/100/1000BaseT POE E Series WS-X4648-RJ45V-E JAE1234SHWX

6 48 10/100/1000BaseT POE E Series WS-X4648-RJ45V-E JAE1234SPBB

M MAC addresses Hw Fw Sw Status

--+--------------------------------+---+------------+----------------+---------

1 0022.90a3.b790 to 0022.90a3.b7bf 1.1 Ok

2 0022.90a3.c7b0 to 0022.90a3.c7df 1.1 Ok

3 0022.55bf.2940 to 0022.55bf.2945 1.2 12.2(44r)SG 12.2(46)SG Ok

4 0022.55bf.2946 to 0022.55bf.294b 1.2 12.2(44r)SG 12.2(46)SG Ok

5 0022.90a3.bdc0 to 0022.90a3.bdef 1.1 Ok

6 0022.90a3.c570 to 0022.90a3.c59f 1.1 Ok

Mod Redundancy role Operating mode Redundancy status

----+-------------------+-------------------+----------------------------------

3 Active Supervisor SSO Active

4 Standby Supervisor SSO Standby hot

Did any one face thios problem before.

When we connected the smart card reader to 3560 swithc its int status is showing 10 mbps full duplex.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 11/16/2008 - 04:02

Hello Shibi,

I would try to force the switch port to use 10 Mbps speed

int g1/1

switchport

switchport mode access

! put it in the desired vlan

switchport access vlan X

speed 10

duplex full

!

for example c6500 ports default to routed mode so it is a good idea to configure the switchport.

Hope to help

Giuseppe

shibi.er Sun, 11/16/2008 - 04:15

Hello Guiseppe,

Thanks for your reply...

We alreday tried that option which you mentioned , All I would like to know is that is there any limitations to the above mentioned line card ?? Bcz when ever i try to connect this device to other switches it will work... i tried in 3560,3750 and even 6509. Everywher it is working except this module????

Giuseppe Larosa Sun, 11/16/2008 - 04:52

Hello Shibi,

here is the data sheet of your linecard

http://www.cisco.com/en/US/prod/collateral/modules/ps2710/ps5494/product_data_sheet0900aecd802109ea.html

WS-X4648-RJ45V-E Cisco Catalyst 4500 E-Series 48-Port 802.3af PoE 10/100/1000 (RJ-45)

it is declared to be capable of 10 Mbps speed.

To see if it is a physical layer problem what happens if you put another switch in the middle like the c3560 ?

Are you able from an SVI on the 4507R to ping the card reader interface ?

We had to do in this way to connect a device with a 10/100/1000 port to an ADM system able to carry ethernet frames over SDH: directly connected there were a lot of errors on the ADM by putting an older switch in the middle everything was fine.

The problem was the timing: when running in 10 Mbps that port was actually a little too fast over the tolerances of the ADM port.

another thought:

have you tried

switchport nonegotiate on the port ?

and what if you use

no keepalive ?

Hope to help

Giuseppe

shibi.er Sun, 11/16/2008 - 05:00

HI Giuseppe.. My problem is that when i connect this card reader port it self is not showing up....Sh interface status is showing (not connected)....I am facing this problem only while connecting to this module....if i connect this device to any other switch it will work. Also I have manually configured my laptop to 10 mbps and half duplex...and connected to this switch. That time it is working !!!! Only facing problem while connecting this device. Since this is a very critical device for our client , we need to provide a genuine reason to them that why it is not working on this module. Hope u undersatnd the situation.

Giuseppe Larosa Sun, 11/16/2008 - 05:31

Hello Shibi,

the card reader has only one NIC I suppose.

Connect it via a C3560 and then the C3560 to the new module.

Our experience with badge readers is not totally positive: some of them need to be reset and some need to have their NIC changed even if they are new and link negotiation is not their strongest feature.

You can say that the card reader NIC is probably too old to take part in negotiation with the new module ports that is technically true.

You need to provide a solution and adding or keeping a C3560 in the network can be an acceptable one.

Hope to help

Giuseppe

glen.grant Sun, 11/16/2008 - 11:51

You might try setting the port to mdix auto . The port interface speed and duplex must be auto , you can't use mdix and hardcode speed . To me it sounds like a physical layer issue where it might need a crossover instead of a straightthru. If mdix was turned on for those other switches it might be why it worked with those. It is not on by default so unless you turned it on it is not on. There is no reason why it should not work if it works on a 3560.

glen.grant Sun, 11/16/2008 - 13:11

Try this on the interface.

conf terminal

interface interface-id

speed auto

duplex auto

mdix auto

Enables Auto-MDIX on the interface.

shibi.er Sun, 11/16/2008 - 22:54

Please find below the output when we connected the card reader in 3560 switch

HGH_RAD4#sh int gigabitEthernet 0/2 status

Port Name Status Vlan Duplex Speed Type

Gi0/2 Help Desk connected 3 a-full a-10 10/100/1000BaseTX

HGH_RAD4#sh run int gi

HGH_RAD4#sh run int gigabitEthernet 0/2

Building configuration...

Current configuration : 201 bytes

!

interface GigabitEthernet0/2

description Help Desk

switchport access vlan 3

switchport mode access

udld port aggressive

no mdix auto

spanning-tree portfast

spanning-tree bpduguard enable

end

Following are the output when we connect the same device to 4507.

HGH_RAD#sh int gigabitEthernet 6/24 status

Port Name Status Vlan Duplex Speed Type

Gi6/24 notconnect 3 auto auto 10/100/1000-TX

HGH_RAD#sh run interface gigabitEthernet 6/24

Building configuration...

Current configuration : 125 bytes

!

interface GigabitEthernet6/24

switchport access vlan 3

switchport mode access

no mdix auto

spanning-tree portfast

end

Please note that I have connected my laptop by manually configuring its NIC to 10 mbps full/half duplex to this 4507 switch. At that time it will work. Only problem we are facing is when connecting this card reader. Since this device is a critical one in clients daily business we have no other options.

glen.grant Mon, 11/17/2008 - 04:53

Please see above message and use that interface config on the 4507 interface and see if it comes up . You currently have no mdix auto on the interface . Change that to mdix auto and see if the port comes active. If that doesn't work you may have to open a TAC case.

Daniel Elani Tue, 03/23/2010 - 18:00

Had a very similar issue, which I managed to fix, just type the

below under the interface config mode:

power inline never

WS-X4648-RJ45V-E is a PoE module which doesn't work well with legacy 10Mbps devices.

Rate it in case it fixed your issue

Actions

This Discussion