Cisco Secure ACS with UCP assistance and enable password

Unanswered Question
Nov 16th, 2008

I am running Cisco Secure ACS version 4.2 running on a

Standalone Windows 2003 Enterprise 2003with the lastest

windows service pack and update. Secure ACS is running

fine and I can authenticate with Cisco routers and

switches. The Windows 2003 server is also running Microsoft

IIS Server. In other words, the IIS server and Cisco

Secure ACS is running on the same windows 2003 server.

I am trying to get Cisco User-Changeable password to work

with Cisco Secure ACS. I followed the release notes lines

by lines and the work around provided below:

Also server require more privileges for the internal windows user that runs CSusercgi.exe.

The name of the windows user that runs UCP is IUSR_<machine_name>.

Workaround steps:

1) Install UCP 4 on a machine that runs IIS server.

2) Open IIS manager

3) Locate Default Web Site

4) Double click on the virtual name 'securecgi-bin'

5) Right click on CSusercgi.exe and choose Properties

6) Choose 'File Security' tab

7) Choose 'Edit' in 'Authentication and access control' area

8) Change username from IUSR_<machine_name> to 'Administrator' and enter his

password (make sure that 'Integrated Windows authentication' is checked)

I still can NOT get this to work. I got this error:

It says:

The page cannot be found

The page you are looking for might have been removed,

had its name changed, or is temporarily unavailable.

HTTP Error 404 - File or directory not found.

Internet Information Services (IIS)

I modified everything in the Windows 2003 to be "ALLOWED" by

EVERYONE. In other words, there are NO security on the windows 2003.

It is still NOT working.

The other question I have is that can Cisco UCP allow user

to change his/her enable password?

Can someone help? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
mehdiraza Tue, 01/04/2011 - 04:31


I've same issue as you stated above, if you find any answer/reply. please let me know too.


Mehdi Raza

mehdiraza Wed, 01/05/2011 - 02:26

Thank you Bastein

Problem has been solved after re-installation of UCP and re-defining of the virtual directories.

Thanks again for your assistance and awesome co-operation/sharing.


Mehdi Raza

Bastien Migette Wed, 01/05/2011 - 04:40

Hello Mehdi,

I'm glad this work.

Please mark the thread as answered and/or rate the post that are useful.



mehdiraza Wed, 01/05/2011 - 06:49

Yes bastien,

Thank you.

But one thing more i want to know that in its Redundant AAA server, when i try to open IIS 6.0 window 2003; it prompts for Username and Password.
I've given it several time; also going through Administrator account with administrative credentials but it always failed.

Any suggestions/solution/?

This time many thanks in advance.


Mehdi Raza

Bastien Migette Wed, 01/05/2011 - 06:57

Hello Mehdi,

Do you mean the password to modify IIS parameters ?

It seems related to windows IIS configuration, so I guess you would have better chances on a microsoft forum.

Sorry if I can't help you further on this part.


This Discussion