c3845 frame-relay qos

Unanswered Question
Nov 17th, 2008

I am trying to create class and policy maps for a frame-relay router c3845 w 12.4 advipserv.

I've managed to create the access-list, class, and policy map, but when I enter the sub interface and try to apply it, I get the message "CBWFQ not support on subints"

On central router

access-list 198 permit ip any

access-list 198 permit ip any

access-list 198 permit ip any

access-list 198 permit ip any

class-map match-any Priority_Traffic_Forest

match access-group 198

policy-map Priority_Traffic_Forest

class Priority_Traffic_Forest

bandwidth percent 50

int Hssi1/0.14

service-policy output Priority_Traffic_Forest

Each subint connects to a different site so I can't apply it to the main interface.

I'm missing something, but not sure what it is. If more info is needed let me know. Thanks in advance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vmiller Mon, 11/17/2008 - 08:51

Using the sub interface may not be supported on this release for this platform. I have the same issue on a different platform

Joseph W. Doherty Mon, 11/17/2008 - 09:35

The issue is, your outbound policy doesn't "know" the amount of bandwidth. On some subinterfaces (don't recall if true for a Hssi frame-relay), issue can be addressed by using a hierarchal policy (with shaper in top level) and/or (perhaps) generic traffic shaper.


int Hssi1/0.14

service-policy output Priority_Traffic_Forest

traffic-shape rate ###


policy-map somename


service-policy Priority_Traffic_Forest

shape average ###

int Hssi1/0.14

service-policy output somename

rhopkins_rcps Mon, 11/17/2008 - 10:32

Not sure if this will help or clear up anything, but this is the config so far on the interface:

interface Hssi1/0.14 point-to-point

description Forest

bandwidth 1544

ip address

frame-relay interface-dlci 408


Would this change things?

Joseph, how would I come up with the shaper rate or average?

Thanks again.

Joseph W. Doherty Mon, 11/17/2008 - 11:00

Assuming your HSSI is running at more than T1, but that your far side might be just a T1 or slower, I would at least shape for far side bandwidth (assuming it's less). This so we control congestion rather than some FIFO default especially on far side PVC egress.

The foregoing is even more imporant when trying to insure VoIP performance. Besides trying to get your policy "to take", we may need to shape perhaps a bit slower (e.g. 1400 for T1?) to account for L2 overhead. You want to insure congestion first forms within your policy where you insure VoIP goes first.


"Would this change things?"

Don't think so. Believe you need to get a shaper, somehow, into the subinterface config.

rhopkins_rcps Tue, 11/18/2008 - 05:12

I think you lost me Joseph, can you point me to a good guide that explains all this? I think some of this is above my head. Thanks for the help.

Mohamed Sobair Tue, 11/18/2008 - 05:22


You will need a nested Policy for this type of config.

a nested policy is configured by creating (Parent & child) policy.



rhopkins_rcps Tue, 11/18/2008 - 12:58

I hope I'm not being greedy here, but could anybody show me a detailed example or a good document so I can learn up on this stuff. Thanks again.

allan.thomas Tue, 11/18/2008 - 15:24

In order to apply CBWFQ and LLQ to FR sub-interfaces, you will have to associate the policy-map within a map-class, take a look at the example below:-

class-map match-all voice-signaling

match access-group 103

class-map match-all voice-traffic

match access-group 102


policy-map voice-policy

class voice-signaling

bandwidth 8

class voice-traffic

priority 45

class class-default



interface Serial0/0

bandwidth 64

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

frame-relay traffic-shaping

frame-relay ip rtp header-compression


interface Serial0/0.1 point-to-point

bandwidth 64

ip address

frame-relay interface-dlci 400

class VOIPovFR


map-class frame-relay VOIPovFR

no frame-relay adaptive-shaping

frame-relay cir 64000

frame-relay bc 640

frame-relay be 0

frame-relay mincir 64000

service-policy output voice-policy

frame-relay fragment 80

access-list 102 permit udp any any range 16384 32767

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any eq 1720


Please take the opportunity review the follow document for further examples:-


Hope this helps.


Pls rate helpful posts.


This Discussion