4507 is not using the default route !!!

Answered Question
Nov 17th, 2008

Hi ,

I have the setup shown in the attached drawing , I dont know why SWITCH_A is not using the default route .

when I try to ping any subnet behind SWITCH_B , SWITCH_A cannot reach it if I didnot specifically add a static route to that subnet pointing to switch_B

ip route !!!

SWITCH_A routing table is:

Gateway of last resort is to network is variably subnetted, 31 subnets, 4 masks

C is directly connected, GigabitEthernet3/6

C is directly connected, Vlan220

C is directly connected, Vlan218

C is directly connected, Vlan216

C is directly connected, Vlan217

S* [1/0] via

Can anyone explain this behavior !!!

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 11 months ago

Okay, so when you run a ping from switch A are you making sure that it is from an interface in either from int vlan 216 or 218 as these are the only 2 networks switch B knows how to get back to.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Jon Marshall Mon, 11/17/2008 - 09:15

Is it just the 10.12.x.x subnets behind B you have tried to ping. If it is altho very unlikely can you make sure you don't have

"no ip classless" in your config on Switch A.


snpatel Mon, 11/17/2008 - 09:20

In the text you stated, your next hop for the static is 10.12.223._253_

In the routing table output, your static default's next hop is 10.12.223._254_

John Blakley Mon, 11/17/2008 - 09:25

You have a VLAN (217) that's a directly connected route. It's going to try to go out that interface before it'll try to leave the switch. That's why it's working if you add the static route.

Are you using a routing protocol like bgp, ospf, or rip?


Richard Burts Mon, 11/17/2008 - 09:34


Is it possible that the addresses configured on the switches are not the same as shown in the drawing. In you example of the static route that works the nest hop is .253, which according to the drawing should be the local interface. If the route with .253 works but the route with .254 does not work then it suggests that perhaps .254 is really the local address and .253 is really the other switch address.

An easy way to demonstrate this would be to post the output of show ip interface brief.



Ali Koussan Mon, 11/17/2008 - 09:49

Hi All,

Sorry ,I did a mistake when I paste the configuration.actually I wrote them , I didnot capture them from the switches to minimize the post.

the route on SWITCH_A is:

ip route (not 254)

and subnet 217 is not directly connected to switch A , please ignore the above output.

I'm sure I dont have basic error, it is exactly as I explained.

no ip classless command is configured.

Yes, I do have EIGRP behind SWITCH_A and the subnet is advertised there.But there is no EIGRP between SWITCH_A, and SWITCH_B

Jon Marshall Mon, 11/17/2008 - 09:51

"no ip classless command is configured"

Sorry but could you be more specific as that could be taken 2 different ways. Are you saying that in your config there is not a line with

"no ip classless"

What IOS version are you running ?


Ali Koussan Mon, 11/17/2008 - 09:55

sorry gain , I mean "no ip classless" is not shown on the configuration

IOS Version 12.2(25)EWA6

John Blakley Mon, 11/17/2008 - 09:57

Well, I would do as Rick suggested by doing a sh ip int brief.

If you can post the sections from sh run:

ip route (all lines)

router eigrp AS (all config)

interface (whatever your OUTBOUND interface is) config

And the ACTUAL routing table would be nice :-)


Ali Koussan Mon, 11/17/2008 - 10:14

please see attached notepad

please dont worry about .253 or .254 order , regardless SWITCH_A has .254 or .253 , the idea should be clear :)

.254 is on SIWTCH_B .253 is on SWITCH_A

Notice that

ip route

ip route

are added to the configuration otherwise the subnets and will not be reachable.

John Blakley Mon, 11/17/2008 - 10:18

Can you post your eigrp configuration from the other switch and the static routes from it?

Jon Marshall Mon, 11/17/2008 - 10:18

You have this in your routing table

D is a summary, 7w0d, Null0

which is because of this entry under your eigrp config


Problem is is on the other switch. But the default route will not be used because you have a more specific route ie.

D is a summary, 7w0d, Null0

so traffic is blackholed. Only when you add in a specific entry for does that get used.

You need to break down your advertisements under your router eigrp config.


Ali Koussan Mon, 11/17/2008 - 10:22

Thanks Jon. I have the same suspect also , but what about ??

Jon Marshall Mon, 11/17/2008 - 10:25

Well that depends. If you have the same config on switch B in terms of summarising then traffic will actually be sent across the link but again Switch B would drop it when it tried to send it back.

This is assuming when you ping the source IP is from summary range.

An easier solution for you would just be to run EIGRP between your switches - is there some reason you are not ?


Ali Koussan Mon, 11/17/2008 - 10:31

Actually , we cannot run eigrp between them , because SWITCH_A and SWITCH_B are in different parts of teh network , they should not share the routing table (IT department policy)

anyway , SWITCH_B has no dynamic routing configured , is simply a vlan on SWITCH_B that need to be reached from SWITCH_A.

Correct Answer
Jon Marshall Mon, 11/17/2008 - 10:34

Okay, so when you run a ping from switch A are you making sure that it is from an interface in either from int vlan 216 or 218 as these are the only 2 networks switch B knows how to get back to.


John Blakley Mon, 11/17/2008 - 10:35

You'll need to add a route for every network that's on switch A to switch B if you're not using eigrp between them for A to see the return traffic back.

So whatever VLANs you need to get to on switch A from B, you'll need a static route for on the B switch.



This Discussion