link won't auto negotiate to 1000mbps

Unanswered Question
Nov 17th, 2008
User Badges:

I have a Catalyst 2960. I've got the port speed set to auto, and the speed and duplex on the NIC (HP NC373i Multifunction Gigabit) on the other end of the cable is set to auto. According to the docs, it should negotiate at 1000mbps full, but it resets at 100mbps full. If I also set the duplex on the switch to auto, it negotiates at 100mbs half. If I try forcing either side to 1000 full while the other side is on auto, the link won't come up.


Help. I am no expert at this, but this seems pretty simple. Any suggestions?


Thanks in advance,

Melinda

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 11/17/2008 - 10:11
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Melinda,

you should find out if the cabling is able to support 1000 Mbps.

GE over UTP requires a complete cabling of all the 4 pairs of wires in a RJ-45 terminated UTP cable.


You can:

try to set to 1000 Mbps full manually and see what happens if the link stays down.


Or have someone test your cabling to see if it is compliant to 802.3ab standards


Or, if you can, try to use a new cat6 straight cable bypassing the cabling and see if the link comes up at 1000 Mbps Full.


Sometimes I've seen that a simple shut / no shut cycle on the port can help to get a successful negotiation


Hope to help

Giuseppe


melindacorrell Mon, 11/17/2008 - 10:17
User Badges:

Guiseppe,

Thank you. It's a new Cat6 straight cable that I'm using.


I'm not sure what you mean by "Sometimes I've seen that a simple shut / no shut cycle on the port can help to get a successful negotiation"


??


Melinda

Giuseppe Larosa Mon, 11/17/2008 - 10:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Melinda,

I was meaning shutting and then reenabling the switch port


int g0/1

shut


then

int gi0/1

no shut


Hope to help

Giuseppe


glen.grant Mon, 11/17/2008 - 11:18
User Badges:
  • Purple, 4500 points or more

You could try and use the cable diagnostic function on the 2960 which acts as a tdr to check to see if you have 4 valid pairs all the way thru. Also check to make sure someone has not hardcoded the nic card settings to 100 meg full .


http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_40_se/command/reference/cli3.html#wp2960803



http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_40_se/command/reference/cli2.html#wpxref33222

Mark Yeates Mon, 11/17/2008 - 11:44
User Badges:
  • Gold, 750 points or more

I would also check and make sure you have the latest NIC drivers installed on your server.


HTH,

Mark

deyadav Mon, 11/17/2008 - 12:24
User Badges:
  • Cisco Employee,

I would suggest to try the followings:


Hardcode the speed and duplex settings on both the end and disable auto negotiation.


On the switchport, config the followings:

switch(config-if)speed nonegotiate

switch(config-if)speed 1000

switch(config-if)duplex full


On the NIC, set the speed to 1000 and duplex to full and disable the option of auto negotiation is available.


Also refer to these documents:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_40_se/configuration/guide/swint.html#wp1028308


http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml


Hope this helps!

Deepak Yadav

melindacorrell Mon, 11/17/2008 - 12:58
User Badges:

I solved the problem, so I thought I would share what worked for me. On the NIC, Autoflow was set to disabled. Apparently, this setting should be auto for 1000 speed. I reset that and was able to get the link to some at 1000 full with both sides set to auto.


Thanks for all suggestions,

Melinda

Actions

This Discussion