BGP dampening

Unanswered Question
Nov 18th, 2008
User Badges:

I have two questions for BGP

first i am trying to put a dampening on router and i am having problem


router bgp XXXX

bgp dampening route-map LLLL


route-map LLLL permit 10

match ip address BBB

set damening 15 750 900 60


ip access-list standard BBB

permit host X.X.X.X


now as soon as i put route-map the frist line the router comes with the follwing message

: %BGP-3-BADROUTEMAP: Bad parameters in the route-map


i mean i can still put the route-map but as soon i type first line route-map LLLL the router gives this error: can someone tell me what i am doing wrong???? secondly in ebgp why we give nexthopself for the neigbour i have seen config my self till now i thought that we only use it in IBGP can someone explain please...


Thanks guys for looking



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Tue, 11/18/2008 - 04:09
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

From your config


"set damening 15 750 900 60" is this a typo or did you just copy into this thread incorrectly ie. you have damening instead of dampening.


BGP next-hop-self


R1(AS 20) -> (AS 10)R2 -> (AS 10)R3


R1 & R2 are EBGP peers.

R2 & R3 are IBGP peers.


R2 receives a route advertisement from R1. R2 will forward this route advertisement to R3 but the next-hop will R1. So if R3 doesn't know how to get to R1 and it probabaly won't R3 will not be able to install this route in it's routing table.


So if you use on R2


router bgp 10

neighbor next-hop-self


then R2 will then advertise the route received from R1 to R3 with a next-hop address of R2. R3 knows how to get to R2 so can use the route.


Jon


Mohamed Sobair Tue, 11/18/2008 - 05:08
User Badges:
  • Gold, 750 points or more


Ading to Jon's,


The suppress limit should be greater than 1000 point. By default, if a route flaps and BGP dampening is enabled, 1000 points is the penalty for the route each time it flaps. you can change this value through normal config.


You need to change the 900 to 2000 or 3000.


HTH

Mohamed

Actions

This Discussion