EIGRP stuck in active when a secondary IP address was being removed

Unanswered Question
Nov 18th, 2008
User Badges:

I have two routers running EIGRP in between (R1 and R2). The neighboring interfaces are:


R1#

interface vlan 10

ip address 10.10.10.1 255.255.255.0

ip address 10.10.8.1 255.255.252.0 secondary


router eigrp 1

network 10.0.0.0

no auto-summary


R2#

R1#

interface vlan 10

ip address 10.10.10.2 255.255.255.0


router eigrp 1

network 10.0.0.0

no auto-summary


EIGRP was running fine until I was to remove the secondary IP. When I was doing that, that EIGRP adjency was flapping and showing "stuck in active".


Is this because the secondary IP's maks covers the primary IP? What did the router do when the secondary IP was removed?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish_zanjurne Tue, 11/18/2008 - 07:01
User Badges:
  • Silver, 250 points or more


hi,


1.In the log , check whether you are getting "Neighbor not on common subnet error" on second router.


2.See in the second router (R2) , if it has form the neighbor relationship with R1 ?


3.Try adding the secondary IP address again , and check neighbor IP Address on both the routers , i am not sure but probably R1 is using secondary IP address as it's ID , and when it is removed it is going into SIA..


HTH...rate if helpful..

glen.grant Tue, 11/18/2008 - 07:28
User Badges:
  • Purple, 4500 points or more

You should specify what the eigrp router id is in the eigrp config , it may have been pointing to the secondary as the previous poster indicated.

gwhuang5398 Tue, 11/18/2008 - 12:46
User Badges:

Hi:

The secondary IP is not the highest IP on the router (it's actually a L3 3750. So Loopback is not configured). So it should not be used as router-id.


Thanks

royalblues Tue, 11/18/2008 - 13:19
User Badges:
  • Green, 3000 points or more

Whenever there is a configuration chnage in the interface running EIGRP, there is a graceful restart of the EIGRP process.


The EIGRP adjacency goes down and comes up..In your case when you removed the sec IP, the graceful restart would have a triggered a set of queries to other neighbors eventually leading to SIA after not receiving any replies


Narayan

gwhuang5398 Tue, 11/18/2008 - 18:00
User Badges:

Hi Narayan:

You made very good sense and I agree most likely the queries for building adjacency somehow caused SIA. I just don't know what could happen to the primary IP when the secondary IP was removed.


interface vlan 10

ip addr 10.10.8.1 255.255.252.0 secondary

ip addr 10.10.10.1 255.255.255.0


The primary IP should provide enough info to form adjacency with 10.10.10.2/24 on the neighbor router.


Thanks.

Giuseppe Larosa Wed, 11/19/2008 - 11:29
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Gary,

from the point of view of EIGRP an IP subnet suddenly disappeared without no topology change: no link went down.


I think that probably the SIA happened and was related about the now missing prefix 10.10.8.0/24.


_From the point of view of the neighbor this IP subnet was reachable to the neighbor 10.10.10.1.

If this interpretation is correct the neighboring router went active for net 10.10.8.0/24.

It has sent out a query to which the neighbor didn't answered, going in SIA for a route the EIGRP adjacency was reset in the hope to restore the original network topology.

This is a standard EIGRP behavior in case of SIA.



This is only a guess. It could be interesting to analyze the log messages on both routers to see if the guess can fit with the observed events / messages.


Hope to help

Giuseppe

Actions

This Discussion