IP accounting question

Answered Question
Nov 18th, 2008
User Badges:

We have Router connected to switch.

here is router port config


interface FastEthernet0/0

description LAN Interface to Customer

ip address 43.131.210.3 255.255.255.0

ip helper-address 43.130.142.11

ip helper-address 43.145.126.12

ip accounting output-packets

service-policy input PolicyMap_2

service-policy output PolicyMap_4

ip route-cache flow

speed 100

full-duplex

end

right now it shows ip accounting is enabled on this port.

ip accounting output-packets

my question is is this IP accounting enabled for packets entering the fa0/0 interface of router ?


many thanks

mahesh

Correct Answer by Jon Marshall about 8 years 5 months ago

Mahesh


In your config above ip accounting will show packets leaving the fa0/0 interface. So if the local LAN is connected to the fa0/0 interface you will see traffic going to your local LAN.


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Tue, 11/18/2008 - 10:14
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

my question is is this IP accounting enabled for packets entering the fa0/0 interface of router ?


No, it will only account for packets leaving the router.


HTH,


__


Edison.

mahesh18 Tue, 11/18/2008 - 11:21
User Badges:

Hi


Thnaks for reply.

so which is best way to enable IP accounting

on Lan inetrface or Serial or ATM interface

of router.

Many thanks

mahesh

Jon Marshall Tue, 11/18/2008 - 12:30
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mahesh


This really depends on what you are trying to see. So for example you have a remote site with a WAN router. If you enable "ip accounting" on the WAN interface then you will get an idea of the traffic going out from the remote site to the rest of your network.


If you enable it on the LAN interface then you will get an idea of the traffic going into the remote site from the rest of your WAN.


So it really depends on what perspective of the network traffic you are trying to see.


Jon

mahesh18 Tue, 11/18/2008 - 12:53
User Badges:

Hi jon,


we have this setting on the router interface

connecting to switch


interface FastEthernet0/0

description LAN Interface to Customer

ip address 43.131.210.3 255.255.255.0

ip helper-address 43.130.142.11

ip helper-address 43.145.126.12

ip accounting output-packets **************

service-policy input PolicyMap_2

service-policy output PolicyMap_4

ip route-cache flow

speed 100

full-duplex

end

as per this setting it shows traffic from local lan entering the fa interface and ip accounting is enabled for packets going out from fa interface to wan?

correct we if i am wrong

Correct Answer
Jon Marshall Tue, 11/18/2008 - 13:02
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mahesh


In your config above ip accounting will show packets leaving the fa0/0 interface. So if the local LAN is connected to the fa0/0 interface you will see traffic going to your local LAN.


Jon

mahesh18 Tue, 11/18/2008 - 13:17
User Badges:

Hi jon

Mant thanks again for getting this clear to me.

mahesh18 Tue, 11/18/2008 - 14:05
User Badges:

Hi jon,


if we have this config on the router lan interface

interface GigabitEthernet0/0

description new Connection to customer LAN

ip address 43.131.82.2 255.255.255.0

ip accounting input-packets

then will it show ip accounting for traffic

coming from lan and going to outside wan?

Actions

This Discussion