Call transfer problem with FXO in UC520 setup

Unanswered Question
Nov 19th, 2008

Hi,

I am facing a call transfer problem between a site to site call and then transfered to a PSTN call.

Setup: site A:ISDN->UC520----------Site B:UC520->FXO

When a call is made From site A IP Phone to Site B ip phone, call is successfuly established. Then if the call is transfered to the PSTN line at siteB then call disconnects immediately after pressing the Transfer button on the IP Phone.

If the first call is made to the PSTN at the site B and then if the call is forwarded to the Site A IP Phone then it works.

When i did the "debug voice ccapi inout" in site B. It shows

"ssCTreRoutingNotSupported=FALSE" and then call is disconnected.

Pls Note: problem is only on the site B. If site B calls site A and if the call is transfered to the Site A PSTN Then it works perfectly.

Pls help...

Thanks

Manoj

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Wed, 11/19/2008 - 05:18

Manoj,

Do you have the following on the Site B UC520?

telephony-service

transfer-pattern .T

Brandon

netstar-sg-service Wed, 11/19/2008 - 17:28

Hi Brandon,

Yes i have transfer-pattern .T in both the sites.

Does it create any problem? FYI, site A call transfer is working fine.

Brandon Buffin Fri, 11/21/2008 - 06:58

Manoj,

It looks like you have a transcoder configured at Site A, but not at Site B. This is why calls success from B to A. You are sending calls across the WAN g.729 (this is the default for voip dial peers), so they would need to be transcoded to be sent out to the PSTN. You can either configure a transcoder at site B or change your config as follows to send calls from A to B as g.711:

Site A

dial-peer voice 86 voip

destination-pattern 1..

session target ipv4:10.86.10.1

dtmf-relay h245-alphanumeric h245-signal

codec g711ulaw

Site B

dial-peer voice 4 voip

incoming called-number 1..

codec g711ulaw

Hope this helps.

Brandon

Actions

This Discussion