cpu usegae high 70 to 80 percent

Unanswered Question
Nov 19th, 2008

Dear Sir,

We are having some problem with a router's cpu usage. Currently it handling only 30 mbps bandwidth. When bandwidth goes to 27 mb its cpu usage reaches to 75% or above. I am attaching some of its configuraiton portion. Could you please let know whether there is any problem or not or its normal with this router.

=====================

sh ver Output:

Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(12g), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2003 by cisco Systems, Inc.

Compiled Mon 11-Aug-03 15:08 by cmong

Image text-base: 0x60008930, data-base: 0x610F6000

ROM: System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Optimax_GW uptime is 1 week, 4 days, 20 hours, 10 minutes

System returned to ROM by reload

System image file is "flash:c3640-is-mz.122-12g.bin"

cisco 3640 (R4700) processor (revision 0x00) with 125952K/5120K bytes of memory.

Processor board ID 19737278

R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

2 FastEthernet/IEEE 802.3 interface(s)

4 Serial network interface(s)

DRAM configuration is 64 bits wide with parity disabled.

125K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

=================

interface FastEthernet0/0

description "Connected To BTCL"

ip address 123.49.0.138 255.255.255.252

no ip redirects

no ip proxy-arp

speed auto

full-duplex

!

interface FastEthernet0/1

description "Connected To Lan Router"

ip address 203.112.79.125 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no ip mroute-cache

speed auto

full-duplex

no cdp enable

!

interface Serial2/0

description "Connected to VSAT"

ip address 202.133.15.106 255.255.255.252

ip route-cache flow

no keepalive

no fair-queue

serial restart-delay 0

no cdp enable

router bgp 38031

bgp log-neighbor-changes

network 114.134.88.0 mask 255.255.255.0

network 114.134.89.0 mask 255.255.255.0

network 114.134.90.0 mask 255.255.255.0

network 114.134.91.0 mask 255.255.255.0

network 114.134.92.0 mask 255.255.255.0

network 114.134.93.0 mask 255.255.255.0

network 114.134.94.0 mask 255.255.255.0

network 114.134.95.0 mask 255.255.255.0

network 114.134.88.0 mask 255.255.248.0

network 203.112.72.0

network 203.112.73.0

network 203.112.74.0

network 203.112.75.0

network 203.112.76.0

network 203.112.77.0

network 203.112.78.0

network 203.112.79.0

network 203.112.72.0 mask 255.255.248.0

neighbor 123.49.0.137 remote-as 17494

neighbor 123.49.0.137 prefix-list default in

neighbor 123.49.0.137 prefix-list bttb out

neighbor 123.49.0.137 route-map localpref in

neighbor 123.49.0.137 filter-list 1 out

neighbor 202.133.15.105 remote-as 24399

neighbor 202.133.15.105 description eBGP with ASIX-HKG AS-24399

neighbor 202.133.15.105 version 4

neighbor 202.133.15.105 prefix-list asixdefault in

neighbor 202.133.15.105 route-map localpref2 in

neighbor 202.133.15.105 route-map asix-prepend out

neighbor 203.112.79.121 remote-as 38031

neighbor 203.112.79.121 update-source Loopback0

neighbor 203.112.79.121 version 4

neighbor 203.112.79.121 next-hop-self

neighbor 203.112.79.121 send-community

neighbor 203.112.79.121 soft-reconfiguration inbound

===================

Thanks in advance.

Tuhin

Dhaka. BD.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ropethic Wed, 11/19/2008 - 02:47

On f0/1 and s2/0 netflow is turned on "ip route-cache flow".

Perform a show processor to see if this is the cause.

Normally netflow is hardware switched 6500, need to get back to you how processed for 3640

Joseph W. Doherty Wed, 11/19/2008 - 03:53

A 3640 is rated at 50 to 70 Kpps. Pushing 30 Mbps, especially if duplex, could easily account for the CPU demand you're seeing. You didn't note whether the high CPU is "interrupt" CPU, but if it is, then it's very likely you've hitting the maximum forwarding capacity of the router.

I've attached a document which will provide you the performance specification for many Cisco routers.

Actions

This Discussion