Call forwarding to voicebox doesn't work

Unanswered Question
Nov 19th, 2008

We're running Cisco Callmanager V.4.3 which is attached to a "Cycos" UMS-system.

On the CCM we're having several hunt-groups which contain phones as well as answering- or fax machines.

For one hunt-group now I'd like to replace the current answering machine by a voice box on the UMS.

For testing purposes I kept the device with it's line on the CCM and simply added a directory number at "Forward All" so that all calls are forwarded to the voice box instead off the answering machine itself answering the calls.

Now we're having the following scenario:

- When calling the directory number (here: -560) directly, the voicebox immediately answers the calls (forwarded calls)

- When calling the -560 directly with attached answering machine (noforwarding to voicebox), the device itself answers the calls

- When calling the hunt group the attached answering machine answers the calls after the hunt-group members have been skipped

BUT

- When calling the hunt-group without attached answering machine (call forward to voicebox) the call is aborted with a fast busy tone

Why does that happen ?

Why isn't the call (via the hunt-group and it's members) being forwarded to the voicebox as being set in the line details on the CCM ?

I hope my explanation is not too complicated to understand and maybe someone of you might have an answer for this.

It really would be helpful !!! :)

Thanks in advance so far !

Regards,

Niclas

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
rob.huffman Wed, 11/19/2008 - 06:06

Hi Niclas,

This is a little hard to explain, but is working as expected. You have to keep in mind that the Call Forward setting on Line Group Member DN's is ignored if the call has routed via the Hunt Pilot setup. So this is why your 4th scenario doesn't work.

"When calling the hunt-group without attached answering machine (call forward to voicebox) the call is aborted with a fast busy tone"

Have a look;

The following describes how the Call Forward settings on individual Hunt member phones are ignored when presented a call via the Hunt feature. Here is a clip;

The concept of hunting differs from that of call forwarding. Hunting allows Cisco CallManager to extend a call to one or more lists of numbers, where each such list can specify a hunting order that is chosen from a fixed set of algorithms. When a call extends to a hunt party from these lists and the party fails to answer or is busy, hunting resumes with the next hunt party. (The next hunt party varies depending on the current hunt algorithm.) Hunting thus ignores the Call Forward No Answer (CFNA) or Call Forward Busy (CFB) settings for the attempted party. This also applies to CFWD ALL settings.

From this doc;

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00803edabe.html#wp107892

The Forward should be applied at the "Hunt Pilot" Level as you have discovered;

Hunt Forward Settings

Forward Hunt No Answer - When the call that is distributed through the hunt list is not answered in a specific time, this field specifies how to forward the call.

Destination This setting indicates the directory number to which calls are forwarded. (This can be the Directory Number of the Cycos VM Pilot)

Forward Hunt Busy - When the call that is distributed through the hunt list is busy in a specific time, this field specifies how to forward the call.

Destination This setting indicates the directory number to which calls are forwarded. (This can be the Directory Number of the Cycos VM Pilot)

Maximum Hunt Timer - Enter a value (in seconds) that specifies the maximum time for hunting.(Used in conjunction with Forward Hunt Busy)

Can you try setting up the CycosPilot DN as the Forward number under the above settings :)

From this good CCM 4.1.3 doc;

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_administration_guide_chapter09186a00803ed664.html#wp1023973

After setting these up as well add the Hunt Pilot DN xxxx as an Alternate Extension under the -560 Voicemail Box :)

Hope this helps!

Rob

NiclasCpm Thu, 11/20/2008 - 01:43

Hi Rob and thanks !

Wow, that's what I call an extensive answer !

Thanks for explaining and for the tip with the hunt pilot.

I added the directory number to it now but now I receive an automated message which asks me to enter the voicebox number.

Usually you get this message when a directory number has no voicebox assigned to it and thus the system doesn't know which voicebox it has to address.

Here's my setup which might be helpful:

1. (CCM => Hunt Pilot) "Forward Hunt No Answer" = checked, "Use Personal Preferences" = unchecked, "Destination" = 560, "Calling Search Space" = None

"Forward Hunt Busy" = no changes/entries made here

(I made above settings by comparing working settings on other Hunt Pilots (with an answering machine as last device))

2. (CCM => Directory Number/line itself) "Forward All, Voice Mail" = Unchecked, "Coverage/Destination" = Blank, "Calling Search Space" = CSS-FWD-CPM (our CSS)

"Forward No Answer External/Voice Mail" = Unchecked, "Coverage/Destination" = 88999 (to the Cycos system), "Calling Search Space" = None

(Above settings are our usual and working settings for all lines with a voicebox)

3. (Cycos => Voicemailbox number) "CIT" (Message Waiting Indicator) = MWI/+49XXXXXXX560 (phone number here Xed-out ;) ), "FAXG3#" = 560, "PHONE#" = 560, "VOICE#" = 560

(Above settings are our usual and working settings for all voicemailboxes)

Well, with the settings above it should work now, but it doesn't. :(

May be the problem be the directory number itself ? It's an analog device and not an IP-phone. Does that make any difference ?

rob.huffman Thu, 11/20/2008 - 06:17

Hi Niclas,

You are most welcome my friend!

Well, you have made some good headway here. I see the only remaining problem being with the Voicemail system not recognising the number that it is receiving after the Hunt sequence. Like you nicely noted you are hitting the opening/open tree type greeting instead of the specified mailbox. You need to determine what is being passed to the Cycos somehow and manipulate the result accordingly. I am a little curious with this setting under the (CCM => Hunt Pilot) "Forward Hunt No Answer"

"Destination" = 560

I would think that this sould be the Cycos VM Pilot number.

You are almost there :)

Rob

NiclasCpm Thu, 11/20/2008 - 07:23

Thanks Rob ! :)

Question: What do you mean with "Cycos VM Pilot number" ? The "88999" as mentioned in CCM => Directory number/line - "Forward No Answer External" (88999 to reach Cycos) ?

rob.huffman Thu, 11/20/2008 - 09:27

Hi Jorge,

Thanks my friend :) It always means a great deal to get such a nice nod from one of your peers (and someone I really admire)! You ROCK!

Cheers!

Rob

rob.huffman Thu, 11/20/2008 - 09:35

Hi Niclas,

I think that perhaps the problem is here in item #1 Change the Forward no Answer to 88999 (if 88999 is the Cycos Pilot/main access #). Also, I should have asked what the actual Pilot# is for this Hunt Group;

1. (CCM => Hunt Pilot) "Forward Hunt No Answer" = checked, "Use Personal Preferences" = unchecked, "Destination" = 88999, "Calling Search Space" = None

"Forward Hunt Busy" = no changes/entries made here

(I made above settings by comparing working settings on other Hunt Pilots (with an answering machine as last device))

This setting in item #2 should not be required as the FNA settings in the Line itself is ignored;

2. (CCM => Directory Number/line itself) "Forward All, Voice Mail" = Unchecked, "Coverage/Destination" = Blank, "Calling Search Space" = CSS-FWD-CPM (our CSS)

"Forward No Answer External/Voice Mail" = Unchecked, "Coverage/Destination" = 88999 (to the Cycos system), "Calling Search Space" = None

(Above settings are our usual and working settings for all lines with a voicebox)

Rob

Actions

This Discussion