UCCX 7.01 LRM service problems

Unanswered Question
Nov 19th, 2008
User Badges:

Hi,


we have installed UCCX 7.01 but we are having problems when starting Cisco Desktop Agent appplication. The error we get:


“A licensing error has occurred. Please try again in five minutes. If the

problem persists, please see your log file or the System Administrator

for details”


I found this error in this document: http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/cad_enterprise/cadenterprise7_0/reference/guide/cad700si.pdf


The document suggests CSA SYN flood mode should be disabled od CRS server, however CSA is not installed, Windows firewall is disabled on client.


There is also this error in Event Viewer:


LRM2005 Unable to retrieve server type profile from LDAP for LRM. Error (22:Could not find specified entry.).


LRM service is running, however i can not telnet to it via port port 65432, not even on localhost itself.


Could the error we get in Event Viewer be relevant to this problem somehow?


Best regards,


Marko

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Anonymous (not verified) Thu, 11/27/2008 - 10:48
User Badges:

To resolve this issue, share the folder on the CRS server, and give the read and write permissions for the agents. In other words, the CAD needs to be able to map a drive to the ProgramFiles\Cisco\Desktop_cfg\Desktop\License folder on the CRS server.


Check the bugs:

CSCsq52914: Starting CAD fails, error message - "A licensing error has occurred.

CSCsh76695: LRM server freezes and accepts connections but doesn't respond to client


Automating DESKTOP_CFG Share Drive Mapping in Cisco Agent Desktop for IPCC Express:

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a00801ecf61.shtml


Unable to Login to Cisco Agent Desktop - Licensing Error:

http://www.cisco.com/en/US/products/sw/custcosw/ps1846/products_tech_note09186a00801f978a.shtml


elavoie Wed, 04/15/2009 - 06:03
User Badges:

Hi, I have the same issue ! Have you fixed it ?

markotisler Mon, 04/27/2009 - 00:18
User Badges:

I had to reintsall UCCX server completely. The problem was that both NICs were activated during installation and it somehow chose the wrong NIC for some services. I disabled the second NIC, did a fresh install and reactivated the second NIC and everything was working fine.

amitkumarp Tue, 10/12/2010 - 04:52
User Badges:

Hi markotisler ,


I have the same issue. But my second NIC card was disabled itself while installing OS. How did you find out that the issue was because of Second NIC??


One more thing, does it really necessary to activate sencond NIC after fresh installation because right now I am using the single NIC only.


Reinstallation of server: Does it mean OS and application or only UCCX application? Your response would be highly appreciative.


Thanking you in anticipation.


Regards,

Amit.

markotisler Tue, 10/12/2010 - 04:59
User Badges:

If your second NIC was disabled during install, you probably just need to change the NIC order (Network Connctions -> Advanced). If this doesn't help, then UCCX repair might. Regarding the uninstall, I reinstalled everything, OS included.

amitkumarp Tue, 10/12/2010 - 05:08
User Badges:

Thanks markotisler for your quick response.


I tried changing the order but it din't work. May be I need to repair the UCCX application.


Actually I have 2 UCCX servers in HA mode. Do I need to repair UCCX on both the servers right? And should I stop all services on secondary server while I repair the first UCCX server?


Regards,

Amit

markotisler Tue, 10/12/2010 - 05:19
User Badges:

If it is a HA environment, I would try forcing the second server to be the master first and see if things work on that one. Also note that the repair procedure may delete some of your configuration, like workflows, so make sure you back up your servers first. Also, if this issue occured only after enabling the second NIC, and all was working fine before, try disabling the second NIC and see what happens.

amitkumarp Tue, 10/12/2010 - 05:32
User Badges:

Thanks again for a really appreciative response. I tried making the secondary server as a master but things din't work and getting the same error.


And its a fresh installation and I had configured some test environment only so no worries even if the configuration gets deleted. And this issue is from the scratch when I installed the server, downloaded CAD from Server and installed on my laptop. I disabled my Firewall, and later I uninstalled antivirus and personal firewall software also. but it dint work. right now I'm just trying to repair it. Hope for the best. Thanks again for your help.


What to do if it doesn't work even after repairing??


I guess I'll have to start from scratch then. I have opened a TAC case also for the same but haven't got such appreciative response like yours.


Regards,

Amit.

amitkumarp Tue, 10/12/2010 - 05:52
User Badges:

Hi markotisler,


It worked. Thats gr8. Thanks alot.. I'll give you 5 for this. Now the issue is only that Agent goes in to not ready state when I call the trigger number from any of the IP Phones. Thanks alot..


Regards,

Amit.

jardalic1 Thu, 11/18/2010 - 01:59
User Badges:

Amit,


what exactly did you do?


Did you force the 2nd node to be the master (for all services) and then run repair on the 1st node?

Because I have one client with UCCX 5.0(2) HA environment and the 1st node has a lot of problems (registry are corrupted, etc) and we agreed to run repair on the 1st node but now I'm trying to find the best way to do it.

For now the to do list is sth like this:

1. backup all data (.wav, scripts, prompts)

2. force 2nd node as a master - it is already in this state

3. run repair

3a. run all patches (SR), if it is needed - to put on the same version as is the 2nd node

4. synchronize data

5. check the status of services

6. restart the 2nd node so the 1st node can become master.


And if it doesn't help then the next step is to run everything from the scratch, but only on that node.


I would appreciate any comments and ideas regarding this repair procedure.


Thanks,

Jelena

Actions

This Discussion