WAAS WCCP help

Answered Question
Nov 19th, 2008
User Badges:

Hi guys,

Please have a look at my topology attached.Right now this is what I have configured on the core:

ip wccp 61

ip wccp 62

int vlan 151

ip wccp 61 redirect in

int vlan 173

ip wccp 62 redirect in


The same is configured on the branch office with the appropriate vlans.


Whatever I do, the "total packets redirected" count never seems to increase. I tried turning on ip wccp 62 redirect out on vlan 173, and ip wccp 61 redirect in on the same vlan, but then only the count for service 61 goes up.


Also, should I use access-lists to permit redirection only to branch offices that have a WAE? If I don't use a redirect-list, shouldn't all packets be redirected to the WAE, and then the WAE would decide whether to optimize or not based on if there's another WAE at the endpoint location?


Here's an output of "sh ip wccp 61 detail"


WCCP Cache-Engine information:

Web Cache ID: x.x.x.x

Protocol Version: 2.0

State: Usable

Redirection: L2

Packet Return: GRE

Packets Redirected: 0

Connect Time: 00:51:22

Assignment: MASK


Any help is greatly appreciated.



Attachment: 
Correct Answer by dstolt about 8 years 8 months ago

The 3560 and the 3750 need to use the sdm templetes that have routing enabled.


sdm prefer routing


THen reload the box and it should start working.


Hope that helps,

Dan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
cfolkerts Wed, 11/19/2008 - 10:55
User Badges:

Since you are performing L2 rewrite under WCCP, you will not see the packets redirected increase. The redirection is handled by hardware instead of software. If redirection was done on a router, you would see packet increases.


I have had WAAS in place for about a year now and you can see below that I have only redirected 2 packets. I am redirecting on a 6509 as well.


mp1swcr01#show ip wccp 61

Global WCCP information:

Router information:

Router Identifier:

Protocol Version: 2.0


Service Identifier: 61

Number of Cache Engines: 2

Number of routers: 2

Total Packets Redirected: 2

Redirect access-list: WAAS_61

Total Packets Denied Redirect: 9179

Total Packets Unassigned: 186

Group access-list: -none-

Total Messages Denied to Group: 0

Total Authentication failures: 0

darkid123 Wed, 11/19/2008 - 10:59
User Badges:

Thanks a lot for your reply.

So what would be the way to verify everything is working properly then?


I'm guessing the following command on the WAE with increasing packets on the "Transparent non-GRE packets received"?


WAAS#sh wccp gre

Transparent GRE packets received: 0

Transparent non-GRE packets received: 1778


There's no way to tell directly on the switch if packets are being redirected properly?


Thanks again.

ropethic Wed, 11/19/2008 - 11:46
User Badges:
  • Silver, 250 points or more

First verify all routers are being seen from the WAE

perform a show wccp routers

to verify if packets are being redirected to wae

show stat dre

show stat tfo

show stat cifs



darkid123 Wed, 11/19/2008 - 12:25
User Badges:

Ok thanks.

I see now that there's traffic being redirected from the 6509's to the WAE at 2 offices. However, the third branch has a 3560 doing the redirection, and I can't get any packets to redirect. The WCCP peering shows up as good/usuable however.


I'm using l2-redirect & l2-return with mask assign. (wccp tcp-promiscuous router-list-num 1 l2-redirect mask-assign l2-return)


Is there any other config that should be different on the 3560?


Thanks!

ropethic Wed, 11/19/2008 - 12:35
User Badges:
  • Silver, 250 points or more

if you post the configs, I will check them for you.

also 3560 minimum IOS for wccp is 12.2(46)SE

darkid123 Wed, 11/19/2008 - 12:40
User Badges:

Aha.

Gotcha.

I'm running:12.2(44)SE2.


XCDSKPA0001#sh ver

Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(44)SE2, RELEASE SOFTWARE (fc2)


I will load the new code tonight and hopefully it will solve my problem.


If not i'll post the configs later.

Thanks so much for your help.

ropethic Wed, 11/19/2008 - 13:41
User Badges:
  • Silver, 250 points or more

No problem, helps me learn as well.

Let me know how you make out,

I am attaching minimum IOS for WCCP across all platforms for WAAS



Attachment: 
darkid123 Wed, 11/19/2008 - 18:59
User Badges:

Ok I updated the code. I'm now running:Cisco IOS Software, C3560 Software (C3560-IPSERVICESK9-M), Version 12.2(46)SE, RELEASE SOFTWARE (fc2)


However, it's still not redirecting any packets.

This is the config I have on the 3560:


ip wccp 61

ip wccp 62

interface Vlan16 //WAN

ip address 192.168.16.253 255.255.255.0

ip wccp 62 redirect in

interface Vlan15 //LAN

ip address 192.168.15.254 255.255.255.0

ip wccp 61 redirect in

interface Vlan21 //WAE Subnet

ip address 192.168.21.254 255.255.255.0


and on the WAE:


interface GigabitEthernet 1/0

ip address 192.168.21.1 255.255.255.0

ip default-gateway 192.168.21.254

wccp router-list 1 192.168.21.254

wccp tcp-promiscuous router-list-num 1 l2-redirect mask-assign

wccp version 2 // I also tried with l2-return


I've attached a few outputs...

Thanks.




Attachment: 
Correct Answer
dstolt Thu, 11/20/2008 - 13:00
User Badges:
  • Cisco Employee,

The 3560 and the 3750 need to use the sdm templetes that have routing enabled.


sdm prefer routing


THen reload the box and it should start working.


Hope that helps,

Dan

darkid123 Fri, 11/21/2008 - 11:38
User Badges:

Nice!

That worked!


Thanks again for all your help...


Actions

This Discussion