HSRP: subinterface on virtual interface

Unanswered Question
Nov 20th, 2008
User Badges:

hi guys,

is it possible to provide a subinterface with dot1q encapsulation on the virtual interface? im planning to use hsrp to provide redundancy on my metro-e. the problem is im using subinterface and encapsulation dot1q. Is this possible using hsrp ?


thanks.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
satish_zanjurne Thu, 11/20/2008 - 01:12
User Badges:
  • Silver, 250 points or more



Hi,


1.You can use HSRP with subinterface as well as SVI interface.


2.HSRP groups on subinterfaces must have a group number unique among all other groups on all subinterfaces on the same main interface. This is because subinterfaces do not receive a unique SNMP interface index. If you had two groups with the number N on different subinterfaces, then in the MIB, group N on sub-interface 1 and group N on sub-interface 2 would appear to be the same group.


3.I did not get your statement "is it possible to provide a subinterface with dot1q encapsulation on the virtual interface?"


HTH...rate if helpful..

jeffersoncbriones Thu, 11/20/2008 - 01:42
User Badges:

Hi Satish,


My current setup is i have a subinterface configured on my router with dot1q where my metro-e clients used as gateway. if use hsrp will i configure this on the 2nd router?

can you provide me a sample.


thanks.

allan.thomas Thu, 11/20/2008 - 03:51
User Badges:
  • Blue, 1500 points or more

In the following example, there is a Voice and Data VLAN, they have been specifically given different priorities so that Router-A is the Active for the Data-VLAN and Standby for the Voice-VLAN, and the exact opposite for Router-B.


Router-A

interface FastEthernet0/0

no ip address

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/0.1

description Data-VLAN

encapsulation dot1Q 10

ip address 192.168.1.2 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 priority 115

standby 1 preempt

!

interface FastEthernet0/0.2

description Voice-VLAN

encapsulation dot1Q 20

ip address 192.168.2.2 255.255.255.0

standby 2 ip 192.168.2.1

standby 2 priority 105

standby 2 preempt

!

Router-B

interface FastEthernet0/0

no ip address

duplex auto

speed auto

no keepalive

!

interface FastEthernet0/0.1

description Data-VLAN

encapsulation dot1Q 10

ip address 192.168.1.3 255.255.255.0

standby 1 ip 192.168.1.1

standby 1 priority 105

standby 1 preempt

!

interface FastEthernet0/0.2

description Voice-VLAN

encapsulation dot1Q 20

ip address 192.168.2.3 255.255.255.0

standby 2 ip 192.168.2.1

standby 2 priority 115

standby 2 preempt


Hope this helps

Allan.


Pls rate helpful posts.

jeffersoncbriones Thu, 11/20/2008 - 04:09
User Badges:

Hi Allan,

What will be the gateway address per vlan? Is it the standby ip address? How bout the peer ip address per vlan? Based on your config, it has different ip address per router and mostly i subnet my ip address.


tia.

Actions

This Discussion