EIGRP summary route learned but not installed in routing table

Unanswered Question
Nov 20th, 2008

I have router R1 and R2 running EIGRP in between. They are in two different locations connected by a Layer 2 metro Ethernet link. Each router is sending and learning multiple /24 subnets for the location through EIGRP.

On the interface of each router, I configured a EIGRP summary route as the following. I can see R1's summary route in R2's EIGRP database and vise versa, and all the more specific routes are not shown accordingly. But the issue is R2 didn't install R1's summary route in its routing table even though the summary route is supposed to have administrative distance of 5. R2's summary route is not in R1's routing table either.

How can I make the summary route into routing table?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Thu, 11/20/2008 - 09:39

Hi Gary,

Can you post the configs of both routers so we can see what is happening there.

Just a little preliminary information:

EIGRP will create a summary route pointing to null0 interface when you use the "ip summary-address eigrp x" command on a router interface.

This summary route will have AD 5 and it is locally significant to the router.

The summary route that should appear in other routers' routing table will keep having AD 90 within the same EIGRP Autonomous System.

Thanks:

Istvan

gwhuang5398 Thu, 11/20/2008 - 12:32

Thanks Istvan. The config is very simple: Fa0/0 is the interface neighboring with each other.

R1#

router eigrp 1

passive-interface default

no passive-interface Fa0/0

network 10.0.0.0

no auto-summary

interface Fa0/0

ip address 10.250.250.1 255.255.255.252

ip aumary-address eigrp 1 10.10.0.0 255.255.0.0

R2#

router eigrp 1

passive-interface default

no passive-interface Fa0/0

network 10.0.0.0

no auto-summary

interface Fa0/0

ip address 10.250.250.2 255.255.255.252

ip aumary-address eigrp 1 10.20.0.0 255.255.0.0

I suppose to be able to see 10.10.0.0/16 in R2's routing table with AD 5 and 10.20.0.0/16 in R1's routing table with AD 5?

Thanks

Jon Marshall Thu, 11/20/2008 - 12:51

"I suppose to be able to see 10.10.0.0/16 in R2's routing table with AD 5 and 10.20.0.0/16 in R1's routing table with AD 5?"

Yes you should. Can you post output of

"sh ip route"

"sh ip eigrp topology"

from each router.

What routers/IOS versions are you running.

Jon

shevchiksv Sun, 11/23/2008 - 16:26

Try manually configure route to null

ip route 10.10.0.0 255.255.0.0 null 0

ip route 10.20.0.0 255.255.0.0 null 0

You can't advertise summary without more specific route in route table so if you configure summary you must have at least 1 more specific route like 10.10.1.0/24, for instance

ullasupendran Fri, 11/21/2008 - 11:51

Hi

Can you check whether the interface that have the ip addresses 10.10 and 10.20 are up/up (just i assumed that u r running in a lab enviorment).If they are not up That can be the issue..

Ullas

Actions

This Discussion