IPv6 Routing Assistance

Unanswered Question
Nov 20th, 2008

I am trying to setup a test IPv6 network. Currently I have built a VMware infrastructure that can handle both IPv4 and IPv6 traffic. I have connected a physical port from the ESX server to begin connecting real world devices. I am trying to implement IPv6 routing on a Cisco 1812 series router. The IOS version is C181X-ADVIPSERVICESK9-M), version 12.4(6)T8. So far I am able to route IPv4 packets across this mixed network of IPv4 and IPv6. I have followed a multitude of directions to get IPv6 working to no avail. Attached is the network topology and the current running configuration from the router.

The router would be placed in between the virtual and physical networks.

Is there someone who could peruse the documents and let me know where I am going wrong?

Thanks for any assistance

Greg

Please move if I placed in the wrong forum section.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 11/20/2008 - 09:34

Hello Greg,

usually on lan interface eui-64 formats are used:

Example:

ipv6 unicast-routing

interface ethernet 0

ipv6 address 2001:0DB8:c18:1::/64 eui-64

I have some doubts on you FE0 config:

interface FastEthernet0

ip address 10.0.3.2 255.255.255.0

duplex auto

speed auto

>>>ipv6 address autoconfig

ipv6 rip process1 enable

!

I would change it with the appropriare eui-64 address.

There is someone that can give an IPv6 address to the router ?

ipv6 address autoconfig

To enable automatic configuration of IPv6 addresses using stateless autoconfiguration on an interface and enable IPv6 processing on the interface, use the ipv6 address autoconfig command in interface configuration mode. Addresses are configured depending on the prefixes received in Router Advertisement messages. To remove the address from the interface, use the no form of this command.

see

http://www.cisco.com/en/US/docs/ios/ipv6/command/reference/ipv6_05.html#wp2114586

http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-addrg_bsc_con.html#wp1282543

Hope to help

Giuseppe

burleyman Thu, 11/20/2008 - 09:51

I noticed your running RIPv2. I don believe it works with RIP 1 or 2....I think you need what is called RIPng (New Generation). I will see if I can find where that is stated.

Mike

greg.bessette Thu, 11/20/2008 - 10:59

Thanks so far.....I am going to make the modifications specified and will let you know.

Greg

greg.bessette Tue, 11/25/2008 - 09:06

I am placing my updated router config. I am still not able to RIP over IPv6. If I run a packet capture on FA1, I can see RIPng responses from the router interface. On FA0, I see nothing from the packet capture.

Thanks for any continued assistance.

Giuseppe Larosa Tue, 11/25/2008 - 09:17

Hello Greg,

I see you are using EUI-64 ip addresses now.

I think the following static routes are not needed:

ipv6 route 2001:DB:0:3::/64 FastEthernet0

ipv6 route 2001:DB:0:4::/64 FastEthernet1

these are exactly the ipv6 subnets out those interfaces.

the same applies for ipv4 :

ip route 10.0.3.0 255.255.255.0 FastEthernet0

ip route 10.0.4.0 255.255.255.0 FastEthernet1

!

Do you see RIP (for ipv4 frames ) on both interfaces ?

Hope to help

Giuseppe

greg.bessette Tue, 11/25/2008 - 09:50

I currently see rip for ipv4 frames on both sides. I can route with no problem using IPv4 after I pulled the static routes as you suggested. IPv6 still does not work.

Thanks

Greg

greg.bessette Tue, 11/25/2008 - 10:33

Here is some additional information. I run the sh ipv6 rip 6route database and I get the following:

IPv6_Router1#sh ipv6 rip 6route database

RIP process "6route", local RIB

For sh ipv6 route, I get the following:

IPv6_Router1#sh ipv6 route

IPv6 Routing Table - 6 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

U - Per-user Static route

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D - EIGRP, EX - EIGRP external

C 2001:DB8:0:3::/64 [0/0]

via ::, FastEthernet0

L 2001:DB8:0:3:21D:45FF:FE89:D376/128 [0/0]

via ::, FastEthernet0

C 2001:DB8:0:4::/64 [0/0]

via ::, FastEthernet1

L 2001:DB8:0:4:21D:45FF:FE89:D377/128 [0/0]

via ::, FastEthernet1

L FE80::/10 [0/0]

via ::, Null0

L FF00::/8 [0/0]

via ::, Null0

Let me know if there is any other information that you may need.

Thanks

Greg

Harold Ritter Tue, 11/25/2008 - 11:11

Greg,

Even if you don't receive any routes from your neighbor, you should at least see the local routes in the rip database. Can you provide a "show ipv6 proto", "show ipv6 int fa0" and "show ipv6 int fa1".

Regards

greg.bessette Tue, 11/25/2008 - 11:16

Here are the results:

IPv6_Router1#sh ipv6 proto

IPv6 Routing Protocol is "connected"

IPv6 Routing Protocol is "static"

IPv6 Routing Protocol is "rip 6route"

Interfaces:

FastEthernet1

FastEthernet0

Redistribution:

None

IPv6_Router1#sh ipv6 int fa0

FastEthernet0 is up, line protocol is up

IPv6 is enabled, link-local address is FE80::21D:45FF:FE89:D376

No Virtual link-local address(es):

Global unicast address(es):

2001:DB8:0:3:21D:45FF:FE89:D376, subnet is 2001:DB8:0:3::/64 [EUI]

Joined group address(es):

FF02::1

FF02::2

FF02::9

FF02::1:FF89:D376

MTU is 1500 bytes

ICMP error messages limited to one every 100 milliseconds

ICMP redirects are enabled

ICMP unreachables are sent

ND DAD is enabled, number of DAD attempts: 1

ND reachable time is 30000 milliseconds

ND advertised reachable time is 0 milliseconds

ND advertised retransmit interval is 0 milliseconds

ND router advertisements are sent every 200 seconds

ND router advertisements live for 1800 seconds

ND advertised default router preference is Medium

Hosts use stateless autoconfig for addresses.

IPv6_Router1#sh ipv6 int fa1

FastEthernet1 is up, line protocol is up

IPv6 is enabled, link-local address is FE80::21D:45FF:FE89:D377

No Virtual link-local address(es):

Global unicast address(es):

2001:DB8:0:4:21D:45FF:FE89:D377, subnet is 2001:DB8:0:4::/64 [EUI]

Joined group address(es):

FF02::1

FF02::2

FF02::9

FF02::1:FF89:D377

MTU is 1500 bytes

ICMP error messages limited to one every 100 milliseconds

ICMP redirects are enabled

ICMP unreachables are sent

ND DAD is enabled, number of DAD attempts: 1

ND reachable time is 30000 milliseconds

ND advertised reachable time is 0 milliseconds

ND advertised retransmit interval is 0 milliseconds

ND router advertisements are sent every 200 seconds

ND router advertisements live for 1800 seconds

ND advertised default router preference is Medium

Hosts use stateless autoconfig for addresses.

Harold Ritter Tue, 11/25/2008 - 12:11

Greg,

Everything looks good except that the RIP database is empty. I would try to upgrade to a more recent image in the 12.4T train.

regards

greg.bessette Mon, 12/01/2008 - 07:15

Here is the latest. I have upgraded to the latest IOS and still have an empty RIP database.

This is the latest config:

Current configuration : 1371 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash:c181x-advipservicesk9-mz.124-22.T.bin

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

dot11 syslog

ip source-route

!

!

!

!

ip cef

ipv6 unicast-routing

ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

ip address 10.0.3.2 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:DB8:0:3::/64 eui-64

ipv6 enable

ipv6 rip 6route enable

!

interface FastEthernet1

ip address 10.0.4.1 255.255.255.0

duplex auto

speed auto

ipv6 address 2001:DB8:0:4::/64 eui-64

ipv6 enable

ipv6 rip 6route enable

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface FastEthernet9

!

interface Vlan1

no ip address

!

router rip

network 10.0.0.0

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

ipv6 router rip 6route

!

!

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

I am going to fire up the second router that I have and see if there may be a hardware issue with this router. I am at a complete loss.

Hopefully I missed something in the config.

Thanks again

Greg

greg.bessette Mon, 12/01/2008 - 09:13

I am now starting to receive this error message. I am try to locate what this error means.

*Dec 1 16:37:19.163: %IPV6_ND-3-CONFLICT: Router FE80::250:56FF:FEAD:1B3E on Fa

stEthernet0 conflicting ND setting prefix 2001:DB8:0:3::/64 valid lifetime, diff

erence 4292375295 seconds

Harold Ritter Mon, 12/01/2008 - 11:08

Greg,

This message should not prevent the router from receiving the RIP routes. Can you do a "show ipv6 rip" and run a "debug ipv6 rip".

Regards

greg.bessette Mon, 12/01/2008 - 11:17

Here are the results for both commands:

show ipv6 rip

RIP process "cisco", port 521, multicast-group FF02::9, pid 44

Administrative distance is 120. Maximum paths is 16

Updates every 30 seconds, expire after 180

Holddown lasts 0 seconds, garbage collect after 120

Split horizon is on; poison reverse is off

Default routes are not generated

Periodic updates 48, trigger updates 2

Interfaces:

FastEthernet1

FastEthernet0

Redistribution:

None

debug ipv6 rip

*Dec 1 19:28:29.715: RIPng: Sending multicast update on FastEthernet1 for cisco

*Dec 1 19:28:29.715: src=FE80::21D:45FF:FE89:D377

*Dec 1 19:28:29.715: dst=FF02::9 (FastEthernet1)

*Dec 1 19:28:29.715: sport=521, dport=521, length=52

*Dec 1 19:28:29.715: command=2, version=1, mbz=0, #rte=2

*Dec 1 19:28:29.715: tag=0, metric=1, prefix=2001:DB8:0:3::/64

*Dec 1 19:28:29.715: tag=0, metric=1, prefix=2001:DB8:0:4::/64

*Dec 1 19:28:29.715: RIPng: Sending multicast update on FastEthernet0 for cisco

*Dec 1 19:28:29.715: src=FE80::21D:45FF:FE89:D376

*Dec 1 19:28:29.715: dst=FF02::9 (FastEthernet0)

*Dec 1 19:28:29.715: sport=521, dport=521, length=52

*Dec 1 19:28:29.715: command=2, version=1, mbz=0, #rte=2

*Dec 1 19:28:29.715: tag=0, metric=1, prefix=2001:DB8:0:3::/64

*Dec 1 19:28:29.715: tag=0, metric=1, prefix=2001:DB8:0:4::/64

*Dec 1 19:28:58.911: RIPng: Sending multicast update on FastEthernet1 for cisco

*Dec 1 19:28:58.911: src=FE80::21D:45FF:FE89:D377

*Dec 1 19:28:58.911: dst=FF02::9 (FastEthernet1)

*Dec 1 19:28:58.911: sport=521, dport=521, length=52

*Dec 1 19:28:58.911: command=2, version=1, mbz=0, #rte=2

*Dec 1 19:28:58.911: tag=0, metric=1, prefix=2001:DB8:0:3::/64

*Dec 1 19:28:58.911: tag=0, metric=1, prefix=2001:DB8:0:4::/64

*Dec 1 19:28:58.911: RIPng: Sending multicast update on FastEthernet0 for cisco

*Dec 1 19:28:58.911: src=FE80::21D:45FF:FE89:D376

*Dec 1 19:28:58.911: dst=FF02::9 (FastEthernet0)

*Dec 1 19:28:58.911: sport=521, dport=521, length=52

*Dec 1 19:28:58.911: command=2, version=1, mbz=0, #rte=2

*Dec 1 19:28:58.911: tag=0, metric=1, prefix=2001:DB8:0:3::/64

*Dec 1 19:28:58.911: tag=0, metric=1, prefix=2001:DB8:0:4::/64

*Dec 1 19:29:28.599: RIPng: Sending multicast update on FastEthernet1 for cisco

*Dec 1 19:29:28.599: src=FE80::21D:45FF:FE89:D377

*Dec 1 19:29:28.599: dst=FF02::9 (FastEthernet1)

*Dec 1 19:29:28.599: sport=521, dport=521, length=52

*Dec 1 19:29:28.599: command=2, version=1, mbz=0, #rte=2

*Dec 1 19:29:28.599: tag=0, metric=1, prefix=2001:DB8:0:3::/64

*Dec 1 19:29:28.599: tag=0, metric=1, prefix=2001:DB8:0:4::/64

*Dec 1 19:29:28.599: RIPng: Sending multicast update on FastEthernet0 for cisco

Harold Ritter Mon, 12/01/2008 - 11:33

Greg,

This router is sending updates but not receiving any. What is the device that we are supposed to be receiving updates from? Whatever it is something seems not to be functioning as it should.

Regards

greg.bessette Mon, 12/01/2008 - 11:51

I had built a VM network using Windows Server 2003 RAS. It is using static routes but the Windows server is sending out router advertisements based on the packect captures. Both the Windows box and the Cisco router are advertising using the link local address going to destination ff02::1.

Would using static routes be the main issue?

I apologize for all the questions but I am new to IPv6.

Thanks

Harold Ritter Mon, 12/01/2008 - 12:07

Greg,

You can use static routes if that satisfies the requirements but if you want dynamic routing updates between the cisco router and the Windows RAS server, you will need to enable RIPng on the server as well. I am not sure whether Windows Server 2003 RAS does support RIPng.

Receiving the router advertisement (RA) on the router will not be a great help unless you use the router as a workstation.

Regards

greg.bessette Mon, 12/01/2008 - 12:33

How should I set up the router then? Should I build a static route with a static IPv6 address? I am researching if I can enable RIPng on Windows Server 2003 RAS.

Thanks

Harold Ritter Mon, 12/01/2008 - 12:53

Greg,

The easiest for now would probably be to configure static routes.

According to your visio diagram, the Cisco router seems to be at the edge of the network. You could install a default route on the Cisco router pointing at the Windows 2003 Server and a static route for 2001:db8:0:3::/64 or 2001:db8:0:4::/64 (depending on which subnet is connecting the router and the server) on the server pointing at the Cisco router.

Regards

greg.bessette Wed, 12/03/2008 - 11:09

I removed most of my VMware infrastructure and connected my 1812 to the 2001:db8:0:1::/64 network and then connected my next 1812 and can perform RIPng across all three networks.

Thanks again for the assistance.

Greg

Actions

This Discussion