Flow control

Unanswered Question
Nov 20th, 2008
User Badges:
  • Bronze, 100 points or more

Hi all,


Can someone please tell me how I turn off flow control on a gigabitethernet interface in a 2851 series router. Software is Version 12.4(3d).


The output of show int gi0/0 shows that output flow-control. See below output:


Thanks for any help!


GigabitEthernet0/0 is up, line protocol is up

Hardware is MV96340 Ethernet, address is 0013.7ff7.1f40 (bia 0013.7ff7.1f40)

Description: XXXXXXXX

Internet address is XX.XX.XX.XX/30

MTU 1500 bytes, BW 4096000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 10Mb/s, media type is T

output flow-control is XON, input flow-control is XON

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 01:31:22

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1061000 bits/sec, 366 packets/sec

5 minute output rate 780000 bits/sec, 373 packets/sec

1629886 packets input, 859123089 bytes, 0 no buffer

Received 0 broadcasts, 10 runts, 0 giants, 0 throttles

11 input errors, 1 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 0 multicast, 0 pause input

0 input packets with dribble condition detected

1613090 packets output, 492951756 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 pause output

0 output buffer failures, 0 output buffers swapped out


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
tcordier Sun, 11/23/2008 - 03:43
User Badges:
  • Bronze, 100 points or more

in interface configuration mode should turn flow control off. I am wondering as it should be disabled by default, can you check the interface configuration?


HTH, Thomas

bmcginn Sun, 11/23/2008 - 14:54
User Badges:
  • Bronze, 100 points or more

Hi Thomas,


I appreciate the response, however I don't get an option of flowcontrol on the interface :(


here is the output..


2851-rtr(config)#int gi0/0

2851-rtr(config-if)#no flowcontrol

^

% Invalid input detected at '^' marker.



Any other suggestions? Thanks for your help, this problem is proving difficult to overcome.


Brad

Giuseppe Larosa Mon, 11/24/2008 - 08:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Brad,

I've verified I have a similar condition on GE ports of C7200VXRs with NPE-G2 and 12.4(20)T but I don't see any issue in my network.

Also from the sh interface you provided flow control is based on IEEE pause frames but your pause frames counters are 0 input and output.

It looks like flowcontrol never took place


What problem do you think is related to flowcontrol in your scenario ?


Hope to help

Giuseppe


Actions

This Discussion