No MOH on gateway

Unanswered Question
Nov 21st, 2008

CUCM 6.1

2811 gateway

MOH is working just fine internally, dn to dn. I've configured the DP to use the MRGL, this is the same DP the gateway uses, and even specified the MGRL in the gateway's config.

I've used the "ccm-manager music-on-hold bind FastEthernet0/0" on the gateway to bind it to the Ethernet port that connects to the CUCM's.

I've made sure the IPVMS has all codecs selected.

Using the "sho ccm music" on the gateway while i've got an external call connected to an internal phone, and on hold, I can see it's connected to the multicasing MOH server address.

Current active multicast sessions : 1

Multicast RTP port Packets Call Codec address

===================================================================

239.1.1.1 16384 0/0 206774 g711ulaw Fa0/0

I've tried removing the voice-class codec from the dial peer so the calls use g729 instead.

The externall caller here's nothing. and voice packets on the "show ccm music" never grow, they always stay zero. This makes me think it's a codec issue, but I'm out of ideas.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
allan.thomas Fri, 11/21/2008 - 10:21

As there are no packets shown for the multicast session, I suspect that your voice-gateway is on a different subnet to CallManager?

Do you have ip multicast routing enabled on your network?

Regards

Allan.

snooter Fri, 11/21/2008 - 11:09

same subnet. they're plugged into the same switch. ip multicast is enabled.

allan.thomas Fri, 11/21/2008 - 11:42

Have tried disabling multicast in order to use unicast instead, the will prove whether it is a multicast issue or not?

If Unicast is successful, then at least you will know that the MRG and MRGL are configured correctly for the gateway.

Regards

Allan

snooter Fri, 11/21/2008 - 13:04

Ok, this is weird. I went in and deleting the MOH audio source, the MRG, MRGL, and totally recreated it. Then, made a call from the cell phone, and the hold music worked for one call. then, for some reason it quit. I did it all again, and now it's not working again..

allan.thomas Fri, 11/21/2008 - 14:31

In order to remove any doubt regarding codecs, try configuring a separate region for your MoH and assign this to a new device pool. Configure the MoH region to use G711 to the Region your gateway is situated.

Then assign the device-pool to the MoH Server and update and reset.

This will ensure that G711 is used explicity between regions. Also ensure that you have configured or allocated your MoH server(s) to your MRG and not left in the default unselected.

Regards

Allan.

ahochau_2 Fri, 01/02/2009 - 14:55

I am having the same issues with h323 gateways. The MoH was working until Octoberish. I reboot the subscriber and MoH works for about 30 minutes, then quits again.

dheavey30 Sun, 01/04/2009 - 11:52

I also have had the same issue several times. With a multicast MOH MRGL on the subscriber I cannot send MoH to PSTN callers. The callers just hear silence. This also seems to be intermittent. I have a dot1q subinterface on the gateway connected to the voice VLAN which is where the UCM subscriber is located. The publisher is on antoher site.

Has anybody out there managed to ever get this working properly with multicast MoH for PSTN calls?

This is with version 6.1.

I have done everything suggested in other posts and it is still the same!

snooter Mon, 01/05/2009 - 11:12

No idea if this is a fix or not, but I removed the check from the "Use Multicast for MOH Audio (If at least one multicast MOH resource is available)" under the MRG list and reset it. It's working though our gateway now just fine..

Also applied the ccm-manager command to our gateway:

ccm-manager music-on-hold bind FastEthernet0/0

Actions

This Discussion