×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

AXl Add Phone but no description is added...

Unanswered Question
Nov 21st, 2008
User Badges:

Im adding a phone with a SOAP AXL request.


My request contains the <description>Test</description> however nothing shows up in the description field...


Everything else seems to populate...



This is on a CCm 6.1 box...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stephan.steiner Tue, 11/25/2008 - 01:55
User Badges:
  • Silver, 250 points or more

Can you look at the axl traces (set level to debug in the serviceability page first) and check if the description makes it to the ccm?

Also, are you using autogenerated stubs from the wsdl or did you write your own code?

Jeff Garner Tue, 11/25/2008 - 09:28
User Badges:

yes from the trace its getting the descripton...


If I set a description on the line that shows up just not on the phone...


This is my own code...



Here is my soap Envelope from the trace...


http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance" xmlns:xsd="http://www.w3.org/1999/XMLSchema">http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://ccmserver/schema/axlsoap.xsd" sequence="1"> BAT00aa3b3c2d67


Test


Cisco 7960Cisco 7960PhoneSCCPUserSS-TESTLABTL-UnRestrictedDP-TESTLABTLTESTLABTLJohn Smith7145551212RouteTESTLABTL-OnNetfalseSS-TESTLABTL-RestrictedOnNettrueSS-TESTLABTL-RestrictedOnNettrueSS-TESTLABTL-RestrictedOnNetDefaultUse System Default42



stephan.steiner Tue, 11/25/2008 - 09:54
User Badges:
  • Silver, 250 points or more

Your XML is incorrect... should include the tag as well.


Can you try again with an XML that corresponds to the schema?


Also, AXL debug tracer or dbl debug traces might show that the request is only have processed.. for some reason you seem to get an OK back though (or you didn't mention that you get any errors).

Jeff Garner Tue, 11/25/2008 - 09:58
User Badges:

In my code I do have the lines tag and the line is added to the phone.. I think the trace seperates the adding of the line and the adding of the phone... I get no error back...


Sascha Monteiro Tue, 11/25/2008 - 18:53
User Badges:
  • Silver, 250 points or more

I think Stephan means that should be at the end, after


can you show the xml that you are sending?

Jeff Garner Mon, 12/01/2008 - 10:00
User Badges:

Here is the soap XML I am sending:


http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">


http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://x.x.x.x/schema/axlsoap.xsd" sequence="1">


SEP001234567890

Test

Cisco 7961

Cisco 7961

Phone

SCCP

User

SS-test-UnRestricted

DP-test

test


7500

John Smith

7500

Route

test-OnNet

false

SS-test-RestrictedOnNet

true

SS-test-RestrictedOnNet

true

SS-test-RestrictedOnNet

Default

Use System Default

4

2






What is interesting is that if I send an updatePhone request and it will update the description.



http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">


http://www.cisco.com/AXL/1.0" xsi:schemaLocation="http://www.cisco.com/AXL/1.0 http://x.x.x.x/schema/axlsoap.xsd" sequence="1">

SEP001234567890

Test


Sascha Monteiro Mon, 12/01/2008 - 10:08
User Badges:
  • Silver, 250 points or more

Jeff,

You have 2 elements, before and after you only need it at the latter.


how do you generate the xml?

Jeff Garner Mon, 12/01/2008 - 10:16
User Badges:

Thanks for catching that as well... Even removing the duplicate /newPhone It still does not add the description...


I am generating the XML with Javascript, Im sending this to the CCm via ActiveXObject("msxml2.xmlhttp.6.0");


I may try and redo this all in ASP...


Actions

This Discussion