Trunk configuration error

Unanswered Question
Nov 21st, 2008

Hi all,

I have created two port-channel trunk links be a MDS9124 and two separate MDS 9124e's. The trunks work, but in Fabric Manager I see three trunks. The other trunk seen in the list is ports that belong to the first port-channel. What am I doing wrong?

Here are the parts of the config of all three switches. The problem is with MDS9124 and MDS9124e-01

switchname MDS9124

interface port-channel 1

switchport description Port-Channel 1 ISL-Trunk to MDS9124e-1 Port-Channel 1

switchport mode E

no shutdown

interface port-channel 2

switchport description Port-Channel 2 ISL-Trunk to MDS9124e-2 Port-Channel 2

switchport mode E

no shutdown

interface fc1/13

switchport mode E

interface fc1/14

switchport mode E

interface fc1/15

switchport mode E

interface fc1/16

switchport mode E

interface fc1/13

switchport description PortGp=1 Member=1 Trunk link to MDS9124e-ext1

switchport trunk mode on

port-license acquire

channel-group 1 force

no shutdown

interface fc1/14

switchport description PortGp=2 Member=1 Trunk link to MDS9124e-ext1

switchport trunk mode on

port-license acquire

channel-group 2 force

no shutdown

interface fc1/15

switchport description PortGp=1 Member=2 Trunk link to MDS9124e-ext2

switchport trunk mode on

port-license acquire

channel-group 1 force

no shutdown

interface fc1/16

switchport description PortGp=2 Member=2 Trunk link to MDS9124e-ext2

switchport trunk mode on

port-license acquire

channel-group 2 force

no shutdown

switchname SQE-MDS9124E-01

interface port-channel 1

switchport description Port-Channel 1 ISL-Trunk to MDS9124 Port-Channel 1

switchport mode E

no shutdown

interface ext1

switchport mode E

interface ext2

switchport mode E

interface ext1

switchport description PortGp=1 Member=1 Trunk link to MDS9124-Port13

switchport trunk mode on

port-license acquire

channel-group 1 force

no shutdown

interface ext2

switchport description PortGp=1 Member=2 Trunk link to MDS9124-Port15

switchport trunk mode on

port-license acquire

channel-group 1 force

no shutdown

switchname SQE-MDS9124E-02

interface port-channel 2

switchport description Port-Channel 2 ISL-Trunk to MDS9124 Port-Channel 2

switchport mode E

no shutdown

interface ext1

switchport mode E

interface ext2

switchport mode E

interface ext1

switchport description PortGp=2 Member=1 Trunk link to MDS9124-Port14

switchport trunk mode on

port-license acquire

channel-group 2 force

no shutdown

interface ext2

switchport description PortGp=2 Member=2 Trunk link to MDS9124-Port16

switchport trunk mode on

port-license acquire

channel-group 2 force

no shutdown

Thanks for your time and help,

Nick

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Michael Brown Mon, 11/24/2008 - 15:59

Nick,

I'm a bit confused. The config above looks correct for your 2 port channels. Could it be that you have a cable between the 9124 and 9124e-01 that is not part of the port-channel and what you see in FM is the port-channel and a parallel ISL? If you mouse over the link on the FM map, it should tell you which ports on each end of the link are in which interfaces. If you see the same port-channel 2 times, it might be a display issue with FM.

Also, there is a display option called 'expand links'. If you mouse over the port-channel link onm FM and click on this, it will not show the port-channel as a single think line, but rather 1 thin line for each link in the port channel. In your example, it would show the port-channel as 2 thin lines, while on the other port-channel, if this option is not in use, that one will appear as a single thick line.

From the CLI there is also a 'show topology' command that I believe will show you what ports on the local switch are attached to what ports on the remote switch.

Hope this helps,

Mike

nickhesson Fri, 12/12/2008 - 15:45

Thanks Mike,

I got pulled off this proble until now. I hear what your are saying. But that is the problem. I see the port channel link with both port as member, then I see another link (parallel) are next to in. But this other link is a member of port-channel. I don't know how to clear this issue.

Thanks,

Nick

I attached a pic of what FM is showing me. You can see the on the top the three links, the first one is my problem. Also, there are only the two ports cabled bewteen the main switch and the two different 9124e's

Attachment: 

Actions

This Discussion

 

 

Trending Topics: Storage Networking