Error Registering Phones: Registration Rejected error DBcon...

Unanswered Question
Nov 21st, 2008

It has been about 2 weeks since we had to deploy a new phone, and today when we tried to deploy a new phone,the message that displayed on the phone was:

Registration Rejected error: DBcon...

So we rebooted pub and sub and still same message. We tried 1 other phone and got the same message. Tried 3Different offfice as well and got same error.

At 1st we thought it was a license issue, so we removed about 20 devices from CM6 that we were no longer using, but same message.

Any suggestions or ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
allan.thomas Sat, 11/22/2008 - 09:48

The symptoms you describe possibly suggest a DBReplication issue between the Pub and Sub.

Have tried to register the new IP Phones with the Publisher? If they register successfully with the Pub and not with the Sub, then here is where the problem is.

You can verify the dbstatus either through the RTMT application plugin or the CLI:-

The 'show tech dbstateinfo' cli command should give a good indication of the dbstates, or alternative verify same through the RTMT database summary. Anything other than a status of 2 is cause for concern..

Hope this helps.


Pls rate helpful posts.

DMobley1022 Sat, 11/22/2008 - 15:04

How would I have them register with the pub instead of sub. Currently we have them auto register. We plug the phone into a port, let it do its thing, and then after about 10 minutes it has a "generic" ext, and then we use that generic ext to configure the phone with all the configurations and correct ext.

I just downloaded the RTMT and installing it right now, I will post the results.

DMobley1022 Sat, 11/22/2008 - 15:10

Okay. I'm in RTMT and not sure where i look to see the db status? The only thing I see initially that draws my attention is service down for:

Cisco Messaging Interface.

DMobley1022 Sat, 11/22/2008 - 15:14

So I went to CallManger-->Service-->Database Summary. Is that the correct place to be?

THere for my pub and sub under replication status it says 2 for sub and 2 for pub. Is that what I'm looking for?

allan.thomas Sun, 11/23/2008 - 04:16

That is exactly what you are looking for, status 2 suggests that your replication is working.

Verify the IP address details on the phones, to ensure that it has a valid IP address, and more importantly a TFTP server address.

The TFTP server address is the TFTP Option 150 in the DHCP scope, unless you have statically assigned them IP addrsses.

What is the exact CUCM version that you are running 6.?.?-?

Hope this helps.


allan.thomas Sun, 11/23/2008 - 13:47

Did you verify the IP Addressing on the Phones, did it have the correct Voice VLAN IP address, and TFTP server address?

Also can you compare the firmware on the new phones to that of an existing one, is it different? Is it an earlier or later release, it is possibly a firmware issue?

Are you using auto-registration? If you are there is a known bug CSCsl90239. This bug states that new SCCP devices cannot auto-register with CallManager. Fixed in version, the workaround is to manually configure the device for registration.

1. Add the IP Phone into CallManager with DN.

2. Ensure that you assign a pre-configured device-pool which has an appropriate callmanager-group consisting of your sub and then pub.

3. Restet the phone.

Hope this helps.


Pls rate helpful posts.

DMobley1022 Mon, 11/24/2008 - 07:03

Verified and it does have the correct VLAN IP and TFTP server address.

Firmware is the same.

We are using auto-registration and we have been for a year now, and this is the 1st time we have had a problem with this. The last time we deployed a phone was about 3 weeks ago and it auto-registered.

Sascha Monteiro Mon, 11/24/2008 - 10:19

can you verify if you still have dn's available in the auto registration range?

also go to route plan report, find and delete all unassigned dn's !

Sascha Monteiro Sun, 11/23/2008 - 12:13

did you change any settings? i.e. devicepool, callmanager group, auto registration, device defaults?

the device pool configured in the device defaults needs to have a cm group with auto-registration enabled, and the 1st cm in the group needs to have it enabled too.

Assuming you are using auto-registration though. (otherwise, if you manually configure the phone, what happens?)

If you suspect db replication, try the following CLI command;

show perf query class "Number of Replicates Created and State of Replication"

And the State must be 2, if not, run the following command;

utils dbreplication reset all



DMobley1022 Mon, 11/24/2008 - 13:06

Figured it out.

In my CM Configuration, under Auto Registration information I had the following:

Starting Directory Number 1800

Ending Directory Number 1899

I looked at this and estimated that we had installed probably right around a 100 phones. So i deleted about 10 phones with the ext 18XX and as soon as I did that, I was able to register the phone I was having problems with as well as another on.

Thank you everyone for your ideas and suggestions.


This Discussion