default route of eigrp

Answered Question
Nov 23rd, 2008
User Badges:

Hi,


How do I config eigrp to advertise the "default route" to nei? any sample config?


rdgs




Correct Answer by Giuseppe Larosa about 8 years 6 months ago

Hello Anita,

on R1 you need also


ip route 0.0.0.0 0.0.0.0 192.168.10.1


R1 can advertise net 192.168.10.0/24 with an externa flag to a third router in net 172.16.0.0/16 via EIGRP


R2 should be out of EIGRP domain


the context is :


R3 -------- R1 --- default network -- GW=R2

<--EIGRP---->



Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
vishwancc Sun, 11/23/2008 - 04:48
User Badges:

Hi,



Use the network command to pass the default route to neighbor.

eg.

router eigrp 110

network 0.0.0.0


Chao

Vishwa



anitachoi3 Sun, 11/23/2008 - 06:31
User Badges:

Hi,


can I use below config?


R1

router eigrp 110

redistribute static


ip route 0.0.0.0 0.0.0.0 192.168.0.1


any dis-adv?


rdgs


Giuseppe Larosa Sun, 11/23/2008 - 06:42
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anita,

another way to propagate a default route in EIGRP is to use the ip default-network command


router eigrp 1

network 192.168.10.0

network 172.16.0.0

!


ip default-network 192.168.10.0


the requirements are:

the network in the default-network has to be in another major network (Class A,B, C)

a network command for it has to be present in the EIGRP process.

In this case the network propagated is that of the default-network with an EIGRP flag that signals the capability to be network of last resort.

It works also if the network is reached via a static route not only if it is a connected subnet.

This command is also supported by RIP but not by link state protocols


note: the router advertising the default route needs to have its own default static route to be able to route to gateway of last resort.


Hope to help

Giuseppe


anitachoi3 Sun, 11/23/2008 - 07:16
User Badges:

Hi Giuseppe,


I config R1 with


R1

router eigrp 1

network 192.168.10.0

network 172.16.0.0

!


ip default-network 192.168.10.0


and


R2

interface fe0/0

ip address 192.168.10.1 255.255.255.0

!

router eigrp 1

network 192.168.10.0 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 210.12.1.1


Is it correct?


rdgs




Correct Answer
Giuseppe Larosa Sun, 11/23/2008 - 07:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Anita,

on R1 you need also


ip route 0.0.0.0 0.0.0.0 192.168.10.1


R1 can advertise net 192.168.10.0/24 with an externa flag to a third router in net 172.16.0.0/16 via EIGRP


R2 should be out of EIGRP domain


the context is :


R3 -------- R1 --- default network -- GW=R2

<--EIGRP---->



Hope to help

Giuseppe


Actions

This Discussion