WAAS - Upgrade from transport to enterprise license

Answered Question
Nov 24th, 2008

Hi

I have a WAE that has a Transport license, and is currently running on version 4.0.17

I need to upgrade it 4.1, and upgrade to an enterprise license (We have bought the license)

Does any1 have a documentation that shows the steps needed to upgrade from transport license to enterprise license?

I have this problem too.
0 votes
Correct Answer by ropethic about 7 years 11 months ago

yes

Yes deregister the branch waes that are not showing up.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
dstolt Mon, 11/24/2008 - 05:45

I would start by using the command line "clear license all" before adding the enterprise license in the GUI. You can also add the enterprise licence via the CLI, however it's easier to apply and track the licenses in the GUI.

Here is the documentation reference on licensing.

http://www.cisco.com/en/US/docs/app_ntwk_services/waas/waas/v411/configuration/guide/other.html#wpmkr1052752

Hope that helps,

Dan

steven-dunn Thu, 11/27/2008 - 16:23

That said, you'll have to go to 4.1 before you can change licenses.

Steve

jorjes1984 Sun, 11/30/2008 - 09:06

Has any done it before?

If i do the upgrade to 4.1, when changing the license mode, i will be asked for which license i want to activate,

I expect i should find only transport license as it is the only one available now,

So my question is how do i add the new bought license to the Device???

do i have to enter any serial number or something like that?

ropethic Mon, 12/01/2008 - 12:04

Yes, I hvae upgraded to 4.1.1. Upgrade the Central manager first to 4.1.1 then you core and then branches.

In 4.1 it is all enterprise licenses which is need to take advantage of the L7 accelerations. There is no transport or CM license any longer.

Important thing is to upgrade CM first.

jorjes1984 Mon, 12/01/2008 - 12:12

Hello,

thanks for the info about upgrading the CM first, i didn't know about it

but i still needs to clear 2 things.

1- When upgrading the Central manager to version 4.1.1, i wouldnt face any problem about the license issue?

2-and later on in the branches WAEs,If the Wae are running now only on the transport license, when upgrading to 4.1.1, i would be asked for which license i want to activate (transport, enterprise, video,....), how can i add the new bought license into the list?

ropethic Tue, 12/02/2008 - 03:16

Licenses are installed and managed only on individual WAE devices, not device groups. Not all licenses are supported on all devices.

To add a license from the WAAS Central Manager, follow these steps:

--------------------------------------------------------------------------------

Step 1 From the WAAS Central Manager GUI navigation pane, choose My WAN > Manage Devices.

Step 2 Click the Edit icon next to the device that you want to modify.

Step 3 In the navigation pane, choose Admin > License Management.

Step 4 Check the check box next to each license that you want to add.

Step 5 Click Submit.

--------------------------------------------------------------------------------

To add licenses from the CLI, you can use the license add EXEC command.

To remove licenses from the CLI, you can use the clear license EXEC command.

To display the status of all licenses from the CLI, you can use the show license EXEC command.

The setup utility also configures licenses when you first set up a new WAAS device

jorjes1984 Fri, 12/12/2008 - 08:05

Hi all

I upgraded the Central manager from 4.0.17 to 4.1.1c using the ISO cd image and got the following result

When upgraded and reloaded, all registered WAE devices disappeared from the device list.

There is only the Central manager showing online,

I tried to reload the Core Wae and the Central manager many times,

and did "no cms enable" then "cms enable" on the core WAE but still nothing appears in the devices list in the Central Manager GUI

PLease help!!!!

ropethic Fri, 12/12/2008 - 15:03

Couple of things:

First,

Try

cms dregister force to remove the waes from registration. then cms enable

If that doesnt work

you may have to upgrade to 4.0.19. i am only mentioning this because when I upgraded my lab from 4.0.15 I had problems. I ugraded to 4.017 then to 4.019 then to 4.1.1B

jorjes1984 Sun, 12/14/2008 - 08:58

Hi

So i downgrade the Central Manager back to the 4.0.17

and then do the upgrade to 0.19 then to 4.1.1C?

And one more question, I am doing the upgrade using and ISO image burned on a CD,

does it matters if i do the upgrade using the ISO image or upgrading via the .BIN file by ftp?

Regards,

ropethic Sun, 12/14/2008 - 15:27

You can use the ISO image from the cd

For the wae-nme in the isr there is no cd drive so you will need to

copy install ftp

Interms of the last upgrade, did you try the cms deregister force command?

You dont have to go back to previous version if the upgrade was successful. However, did you upgrade the CM first to 4.1? In 4.0 the CM got upgraded last, opposite now with 4.1.

If you are unable to see the branch core waes then try the deregister first.

If that doesnt work, what version were you running prior to the upgrade? What were the exact upgrade procedures you employed?

jorjes1984 Mon, 12/15/2008 - 00:00

Hello

I didn't try the cms derigister force command yet, as i have to do it at the client site.

The upgrade was successfull, what i did is:

I had the Central manager, 2 wae appliances and 7 modules, all in version 4.0.17

And what i did till now is that i only upgraded the Central manager using the ISO CD to version 4.1.1.c, and when i reloaded it, i had an error about the license issue,

and did show license, and added the Enterprise license (it was available), and after reloading, the error disappeared.

I will did ASAP the deregister command and get back to to you about the results,

Best regards,

jorjes1984 Wed, 12/17/2008 - 09:04

Hello

i did upgrade today to a branch module WAE to the same version as central manager(4.1.1c), applied the "cms deregister " command, and the branch is still not showing in the CM devices

i did restore factory-default on the Central manager, and did all the settings again and registered the Branch device and its still not showing in the devices

when i do "Show cms info" In the branch wae, i see that cms is running, but in the status it is showing: PENDING (CM is busy,...)

Please advise what could i do to operate back the WAAS.

ropethic Wed, 12/17/2008 - 11:34

TRY CMS DEREGISTER FORCE on the Central manager and then the core and branch waes .

Did you try the dregister before going back to factury default?

jorjes1984 Wed, 12/17/2008 - 13:35

I tried only on the central manager,

Do i put it also on the other WAES?

Correct Answer
ropethic Wed, 12/17/2008 - 15:29

yes

Yes deregister the branch waes that are not showing up.

Actions

This Discussion