Configuration of new ATM WAN connection

Answered Question
Nov 24th, 2008
User Badges:

I have established a new ATM/DSL from my service provider and i have cisco 1841 router. May help me to configure my router?

Note i have a TG605s Thomson modem for direct connect to ATM circuit then RJ45 Ethernet from modem to cisco 1841 WAN module.

My circuit information is:


PVC number 1/311

interface ATM0/0.35 point-to-point description ATM0/0.35 atm pvc vpi=0 vci=35.

By VPNSC: Job Id# = 23186

ip address 172.31.148.174 255.255.255.252

pvc 0/35 encapsulation aal5snap

router bgp 64555 neighbor 172.31.148.173 remote-as 65000 redistribute connected

metric 1

no auto-summary

Correct Answer by Giuseppe Larosa about 8 years 4 months ago

Hello Mostafa,


here it is:


SiteA:


router bgp 64555

no auto-summary

no sync

neigh 172.31.148.173 remote-as 65000

network 172.18.6.0 255.255.255.0

!


note:

you are probably in a L3 MPLS VPN service.

In this case your router has an eBGP session with the PE node of the service provider.


the same is done on HQ


HQ


router bgp 64555

no auto-sum

no sync

neigh x.x.x.x remote-as 65000

network 172.18.0.0 255.255.255.0

!


the Service Provider signalling infrastructure will propagate your advertisements end to end and you will receive the remote lan IP subnet as originated in AS 65000.


Hope to help

Giuseppe


Correct Answer by Giuseppe Larosa about 8 years 4 months ago

Hello Mostaba,

no PPPoE and no need for NAT.


for BGP you just need to advertise the local lan IP subnet


router bgp xxx

network local.lan local.lan.mask

no auto-summary

!

you have already the neighbor statement configured.


Hope to help

Giuseppe




Correct Answer by Giuseppe Larosa about 8 years 4 months ago

Hello Mostafa,

some more information is needed:


in the current setup the router lan interface is configured for:


a) receiving an ip address via DHCP

check if there is ip address dhcp or there is an ip address manually assigned


b) uses PPPoE encapsulation and receives an ip address during PPP negotiation:

check if there are commands containing

pppoe keyword under the fas interface


Depending on the find outs the configuration follow.


If not using PPPoE you have Classic IP over ATM.


int atm0/0

no shut

int atm0/0.35 point-to-point

ip address 172.31.148.174 255.255.255.252

ip nat outside

pvc 0/35

encapsulation aal5snap


notice in this case you may need to configure NAT to make clients on the LAN able to surf the internet


int fas0/0

ip nat inside

!


ip nat inside source list 1 interface atm0/0.35 overload


access-list 1 permit lan.subnet lan.wildcardmask


If using PPPoE config is different but I think you should be fine with this


Hope to help

Giuseppe




check on the lan interface

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (3 ratings)
Loading.
Correct Answer
Giuseppe Larosa Mon, 11/24/2008 - 02:55
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mostafa,

some more information is needed:


in the current setup the router lan interface is configured for:


a) receiving an ip address via DHCP

check if there is ip address dhcp or there is an ip address manually assigned


b) uses PPPoE encapsulation and receives an ip address during PPP negotiation:

check if there are commands containing

pppoe keyword under the fas interface


Depending on the find outs the configuration follow.


If not using PPPoE you have Classic IP over ATM.


int atm0/0

no shut

int atm0/0.35 point-to-point

ip address 172.31.148.174 255.255.255.252

ip nat outside

pvc 0/35

encapsulation aal5snap


notice in this case you may need to configure NAT to make clients on the LAN able to surf the internet


int fas0/0

ip nat inside

!


ip nat inside source list 1 interface atm0/0.35 overload


access-list 1 permit lan.subnet lan.wildcardmask


If using PPPoE config is different but I think you should be fine with this


Hope to help

Giuseppe




check on the lan interface

mtarabay08 Mon, 11/24/2008 - 04:04
User Badges:

Hello Qiusiar,

a)the router LAN interface will be configured to manual assigned IP.

b)no need to use PPPoE because this router to VLAN-to-VLAN (Branch-to-HQ office) connection through our Service provider IP-VPN/ATM cloud.


VLAN01: 172.18.6.0/24 Branch

VLAN02: 172.18.0.0/24 HQ office

mtarabay08 Mon, 11/24/2008 - 04:10
User Badges:

Hello Qiusiar,

Also i asked:

Is there no configuration needed into BGP?

Correct Answer
Giuseppe Larosa Mon, 11/24/2008 - 04:17
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mostaba,

no PPPoE and no need for NAT.


for BGP you just need to advertise the local lan IP subnet


router bgp xxx

network local.lan local.lan.mask

no auto-summary

!

you have already the neighbor statement configured.


Hope to help

Giuseppe




mtarabay08 Mon, 11/24/2008 - 04:23
User Badges:

Thanks,

May i have you post the BGP configuration regarding to the data specified because this is the first time i configure cisco BGP?

Correct Answer
Giuseppe Larosa Mon, 11/24/2008 - 05:16
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mostafa,


here it is:


SiteA:


router bgp 64555

no auto-summary

no sync

neigh 172.31.148.173 remote-as 65000

network 172.18.6.0 255.255.255.0

!


note:

you are probably in a L3 MPLS VPN service.

In this case your router has an eBGP session with the PE node of the service provider.


the same is done on HQ


HQ


router bgp 64555

no auto-sum

no sync

neigh x.x.x.x remote-as 65000

network 172.18.0.0 255.255.255.0

!


the Service Provider signalling infrastructure will propagate your advertisements end to end and you will receive the remote lan IP subnet as originated in AS 65000.


Hope to help

Giuseppe


Actions

This Discussion