6509 doesn't allow 'xmodeming' a new boot loader into MSFC

Unanswered Question
Nov 24th, 2008
User Badges:

Hi all!


I have a major problem with a 6509 supervisor engine (WS-X6K-SUP1A-2GE). I have lost the boot loader in the MSFC1 and I cannot upload a new boot loader image.

I run the supervisor switch engine in Rommon mode first and load the image from flash card (slot0:) manually with the command BOOT=slot0:c6sup11-jk2s-mz.121-26.E4.bin. After this, the supervisor gives command to the MSFC (router). At this point, I try to upload the boot loader with the xmodem function with the command 'xmodem -c -s9600' as specified in the instructions found on the Cisco website, but the upload fails after 7% of the upload is complete and the system crashes, giving out on screen the following error output:

*** System received a Software forced crash ***

signal= 0x17, code= 0x24, context= 0x61a38354

PC = 0x6012f818, Cause = 0x1820, Status Reg = 0x34018002

rommon 2 >


and returns into supervisor mode.

Please help! What is the problem? Thanks,

Stef

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 11/24/2008 - 05:52
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Stefania,


notes


his procedure can take up to 35 to 45 minutes. Also, the first Xmodem transfer can fail with this error message:


"Error : compressed image checksum is incorrect 0xBAA10EAA

Expected a checksum of 0x6F65EA12


*** System received a Software forced crash ***

signal= 0x17, code= 0x5, context= 0x0


PC = 0x800080d4, Cause = 0x20, Status Reg = 0x3040d003"


>>>Do not reset the RP. Issue the xmodem command again, and wait 35 to 45 minutes. This time, the transfer succeeds.


from


http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008015bfa1.shtml#xmodem


You need to do it another time


Hope to help

Giuseppe



Giuseppe Larosa Mon, 11/24/2008 - 06:32
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Stefania,

have you tried without resetting the RP at each attempt ?


If so I would ask for replacement (Cisco RMA or via a partner)


Hope to help

Giuseppe

stefania.castagnolo Mon, 11/24/2008 - 06:41
User Badges:

Hi giuseppe! Yes, I have tried but the switch was complaining about resetting...no reset, no reboot!

Actions

This Discussion