Missing interfaces in NetFlow data with Hybrid OS

Unanswered Question
Nov 24th, 2008
User Badges:

Hi,

We have Cisco 6509 (Hybrid OS) with NetFlow configured on it and we have configured the Cat OS with SUP2 for export of NetFlow data.

In the software, we are unable to see all the interfaces from the switch part, though they are UP and there is traffic flowing through them. The switch ports which do not show up are no different from the other ports. All the NetFlow enabled VLAN interfaces show up. Please find below the version of the SUP & MSFC:

SUP:

WS-C6509 Software, Version NmpSW: 7.3(1)

MSFC:

IOS (tm) MSFC2 Software (C6MSFC2-PSV-M), Version 12.1(13)E12, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)


The SUP config is as below:

set mls nde <IP_Address> <Port>

set mls nde version 7

set mls agingtime long 64

set mls agingtime 32

set mls flow full

set mls bridged-flow-statistics enable 1-4,6-11,16-17,19,100,201-202,666,777

set mls nde enable


Any possible issues or reasons on why this is happening?


Regards,

Don

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
stefankuenkel Tue, 11/25/2008 - 04:17
User Badges:

Hi,


You have to set the flow-mask to 'interface-full'. This will add the input and output interface-indices to the flow information.


set mls flow interface-full


Regards,

Stefan

linker.team Tue, 12/02/2008 - 04:53
User Badges:

Hi Stefan,


Thanks for that. I will certainly give it a try and give an update.


Regards,

Don

Actions

This Discussion