Frame Relay interconnecting with E1

Unanswered Question
Nov 24th, 2008

I have two site, one side is E1 2 mbps and other side is Frame Relay 2 mbps.

I have problems that I loose my packets, I will copy my ping output:

Site_A#ping 192.168.1.38 rep 400

Type escape sequence to abort.

Sending 400, 100-byte ICMP Echos to 192.168.1.38, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!.!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!.!!!!!!!!!!!!!!!!!!!

Configuration:

*** Site A E1:

controller E1 1/0

framing NO-CRC4

channel-group 1 timeslots 1-31

description 2 Mbps Site A

interface Serial1/0:1

description 2 Mbps Site A

bandwidth 2048

ip address 192.168.1.37 255.255.255.252

encapsulation frame-relay

load-interval 30

max-reserved-bandwidth 100

*** Site B Frame Relay:

interface Serial0/1/0

description Site B

bandwidth 2048

no ip address

encapsulation frame-relay

load-interval 30

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi

max-reserved-bandwidth 100

interface Serial0/1/0.1 point-to-point

description Site B

bandwidth 2048

ip address 192.168.1.38 255.255.255.252

snmp trap link-status

frame-relay interface-dlci 517

class CIR2048

map-class frame-relay CIR2048

frame-relay cir 2048000

frame-relay bc 20480

frame-relay be 0

frame-relay mincir 2048000

Please if sombary have some ideas becose I am despart.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Mon, 11/24/2008 - 12:08

How busy are your frame-relay interfaces, in/out both routers, when you do your ping tests?

What's your purchased CIR, both directions?

How busy (CPU) is the ping target router?

aniss12345 Mon, 11/24/2008 - 12:20

Procesor is ok.

Yes we purchased CIR in both directions 2 mbps.

Only traffic is when I ping nothing else.

I am confused, I think thats something wrong on Service provider side but I am not sure.

Thanks

Giuseppe Larosa Mon, 11/24/2008 - 12:27

Hello Anis,

you are trying to use all the channels B of an E1 but I'm not sure you can.

I remember I had a similar issues some years ago: using a traffic generator I was not able to have more then 1984 Kbps on the link.

The difference is exactly one B channel that is used for framing.

try to reduce your shaping rate and repeat the test

Hope to help

Giuseppe

Joseph W. Doherty Mon, 11/24/2008 - 12:33

Given the conditions you cite, routers aren't busy, CIR 2 Mbps and no other traffic but the ping test, I would expect 100% ping success.

Next thing to do might be to look at the interface stats (both your routers) and insure they don't show any errors, like CRC errors.

You might also try other tests, like pings through the routers (i.e. from end hosts, not the routers on each of the frame-relay WAN connected networks). This to see if results the same.

Ping tests with maximum size and/or variable size and/or variable content. Again to see if results the same.

Debug mode to see which packets are being lost, i.e. the reply, response or both. Ping from far side to near side, once again to see if results the same.

Involvement of frame-relay vendor once you can better ascertain where packets are being lost.

Further analysis can get much more involved, but vendor might also quickly see something like CRC errors on their interface that would point to a problem area.

Other posters might have other suggestions.

Actions

This Discussion