DynDNS on 1800 not working after following Cisco guide or SDM?

Unanswered Question
Nov 24th, 2008
User Badges:

Hi

I've setup an account with DynDNS and I've tried to configure my 1800 router to update this host record, either via CLI or through the use of the SDM, yet neither method seems to be working. I've included my dyndns config for your review;


ip ddns update method sdm_ddns1

HTTP

add htp://mccwindsor3:mccwindsorxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname/nic/update?system=dyndns&hostname</A>=<h>&myip=<a>

remove htp://mccwindsor3:mccwindsorxxxxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 28 0 0 0

!


and under my dialer interface i've got;


ip ddns update hostname mccwindsor3.dyndns.org

ip ddns update sdm_ddns1


I've enabled ddns debugs, yet I see nothing in the logs, and the hostname never updates with the proper address. I can ping internet hosts by name from the console of the router with no problems and I've even gone so far as to add;


ip inspect default tcp router-traffic


to the inspect applied to the outbound of my dialer and still nothing. Any ideas? I've set this up on other routers with no problem in the past. Thanks


J


EDIT, sorry for the underlines, not sure how to remove them :(


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jasonhumes Mon, 12/01/2008 - 04:32
User Badges:

Hi

Sorry, I was trying to get this forum to remove the blue underlining of links, so I tried to change the HTTP to HTP, the real config does say HTTP not htp. Any other ideas? Thanks


J

hemal_patel@baa.com Mon, 12/01/2008 - 16:34
User Badges:

Just make sure you have "ip domain lookup" or "ip domain-lookup" (which it should be by default). If you don't have it, it won't be able to translate the URL to IP.


Then make sure you have "ip name-server" configured eg "ip name-server 4.2.2.2" (which is a free public DNS server). I have my ISPs DNS servers configured and the one above.

Actions

This Discussion