Unable to connect to ANI Server

Answered Question
Nov 24th, 2008
User Badges:

I'm running LMS 3.1 with CM 5.1.0 on a single Solaris 9 server. I've been unable to open topology services. I get an error "cannot connect to ANI server". I've confirmed that the ANIServer6.0 is running (it says "Running with busy flag set"). I've also tried restarting the Daemon Manager. What should I look at? Could it be a Java problem?


Correct Answer by Joe Clarke about 8 years 7 months ago

One thing I find does work, though it's not fully tested is to modify the server hosts file so that the fully-qualified name comes first:


10.1.1.1 cisco01.domain.com cisco01


Then, shutdown dmgtd, remove NMSROOT/lib/csorb/NS_Ref, and restart dmgtd. While this will allow the NameServer to send out a fully-qualified domain name, other things may still fail if the short hostname is not reachable from the client. therefore, my client hosts file option is preferred.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Mon, 11/24/2008 - 12:23
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

As stated earlier, you need to be able to connect from the client to the server on TCP ports 42342 and 43242. You should be able to telnet to these ports from the client and get a successful connection.


TCP port 42342 is bound by the NameServer daemon, and 43242 is bound by the ANIServer daemon. Make sure the NameServer daemon is running properly.


If both daemons are running correctly, and you do not get a successful TCP connection from the client, then check for firewalls and/or ACLs between the client and server which may be blocking these ports.

sirbaughmf Tue, 11/25/2008 - 07:47
User Badges:

Verified that the nameserver daemon is running and both ports are open and accessible.

Joe Clarke Tue, 11/25/2008 - 07:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the Java Web Start console, and the NMSROOT/MDC/tomcat/logs/stdout.log.

sirbaughmf Tue, 11/25/2008 - 08:17
User Badges:

I am unable to post the logs, but I did see this in the Java console:


org.omg.CORBA.TRANSIENT:Retries Exceeded, couldn't reconnect to 'servername':42342


I have limited access to the hard drive on my PC, could this be permissions problem with the java directory?

Joe Clarke Tue, 11/25/2008 - 08:19
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This indicates that your client cannot connect to port 42342 on the server. Make sure you can do:


telnet servername 42342


From your client. This must connect. If not, something is blocking tcp/42342.

sirbaughmf Tue, 11/25/2008 - 08:46
User Badges:

When I try to telnet it appears to connect, but i get a blank screen, no prompt...appears to be connected....should I see a prompt.

Joe Clarke Tue, 11/25/2008 - 08:47
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This sounds correct. If you cannot post the logs, I suggest you open a TAC service request to troubleshoot this further.

sirbaughmf Mon, 12/01/2008 - 11:23
User Badges:

One last think before I open a TAC, I noticed in the documentation the following...


"The CisoWorks client must be able to resolve the hostname of the CiscoWorks server to server's IP Address, through DNS."


The servername is cisco01, I have an entry in the hosts file with IP, cisco01, cisco01.state.gov. DNS has the server resolved to the FQDN (second entry in hosts), since the ANI DB is ANIServer6.0-cisco01 would that present a problem with DNS? a problem with Topology Services being able to connect to the DB?



Joe Clarke Mon, 12/01/2008 - 14:31
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The client will be handed something like cisco01:42342 as a CORBA connection address. the client must be able to resolve this hostname. That is, from the client, you should be able to do:


telnet cisco01 42342


And get a connection.

sirbaughmf Tue, 12/02/2008 - 06:56
User Badges:

Ok, I think we are onto something. I am unable to resolve just the hostname or telnet/ping to the hostname.


In DNS we have the FQDN, my guys here say we can't add just the servername to DNS, it must be FQDN...how do we get around this?


They mention WINS, but I'm on a UNIX platform... is there another workaround?

Joe Clarke Tue, 12/02/2008 - 08:23
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

On your client, add the short hostname to your C:\WINDOWS\system32\drivers\etc\hosts file. If your client is also on Solaris, add the short hostname to /etc/hosts, and make sure files is listed for hosts in /etc/nssswitch.conf.

sirbaughmf Tue, 12/02/2008 - 08:32
User Badges:

I found hostnamechange.pl, can this be used change the domain only? Would this append the domain to the server when it tries to reach servername:42342?

Joe Clarke Tue, 12/02/2008 - 08:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

No, this will not help. The hosts file option is the easiest way to go.

Correct Answer
Joe Clarke Tue, 12/02/2008 - 09:08
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

One thing I find does work, though it's not fully tested is to modify the server hosts file so that the fully-qualified name comes first:


10.1.1.1 cisco01.domain.com cisco01


Then, shutdown dmgtd, remove NMSROOT/lib/csorb/NS_Ref, and restart dmgtd. While this will allow the NameServer to send out a fully-qualified domain name, other things may still fail if the short hostname is not reachable from the client. therefore, my client hosts file option is preferred.

sirbaughmf Tue, 12/02/2008 - 10:19
User Badges:

That seems to have worked! I'll continue testing to see if there are any other problems. I also tried changing the /etc/nodename to the FQDN and that worked as well. However, I was concerned about what would happen if the server rebooted, so I changed that back.

Actions

This Discussion