Error trying to TFTP to a server

Unanswered Question
Nov 24th, 2008

I am getting the below error when I try to TFTP to a server in our domain. Any ideas. I checked the permissions on the target directory and it is good, in fact I opened it wide open to test and get the same error. I can TFTP to my laptop fine. The servers are domain controllers running windows 2003.

Switch#copy bootflash: tftp:

Source filename []? cat4000-i9s-mz.122-25.EWA4.bin

Address or name of remote host []? 10.89.3.31

TFTP: error code 2 received - Access violation

%Error opening tftp://10.89.3.31/cat4000-i9s-mz.122-25.EWA4.bin (Permission denied)

Thanks,

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mark Yeates Mon, 11/24/2008 - 14:05

Mike,

Is there any chance of any security software on your server? Don't forget Windows 2003 does have

Windows firewall. Also ensure you have Write permissions on the TFTP directory on the TFTP server.

HTH,

Mark

burleyman Mon, 11/24/2008 - 14:13

I thought of that.....it is disabled. I don't see anything in the event logs as well.

The reason TFTP is on the doamin controllers is it is needed for RIS.

Mike

Jon Marshall Mon, 11/24/2008 - 14:05

Mike

Couple of things

1) Are you sure that there is no subdirectory under 10.89.3.31 that you should be including in your tftp string

2) What is the tftp server you are running and what account is it running as ?

Jon

Richard Burts Mon, 11/24/2008 - 14:12

Mike

Also be aware that in some implementations of the TFTP server, the file must already exist in the directory (though that is more typically *nix than Windows).

Also are you sure that the TFTP service is running?

HTH

Rick

burleyman Mon, 11/24/2008 - 14:16

Service is running. It is running on a domain controller for RIS installs. I have done this before...maybe last year was the last time. The default location for this is the e:\remoteinstall I made the permissions on it everyone full just to test and still no luck.

Mike

burleyman Tue, 11/25/2008 - 04:41

I have traced it back to an issue on the server as I can do this to my laptop. Thanks everyone for your help.

Mike

ken.martinson1 Thu, 03/26/2015 - 17:56

This worked for me:

sudo apt-get install xinetd tftpd tftp

# nano /etc/xinetd.d/tftp , enter the following:
service tftp
{
protocol = udp
port = 69
socket_type = dgram
wait = yes
user = nobody
server = /usr/sbin/in.tftpd
server_args = /tftpboot
disable = no
}

sudo mkdir /tftpboot
sudo chmod -R 777 /tftpboot
sudo chown -R nobody /tftpboot

sudo service xinetd restart

 

on linux:

# nano /etc/selinux/config , enter the following:

SELINUX=disabled
SELINUXTYPE=targeted
SETLOCALDEFS=0

# flush the iptables to disable them.
iptables -F

# create the files and put "chmod 777" on them.

cd /tftpboot
touch startup-config
chmod 777 startup-config
touch c2950-i6q4l2-mz.121-19.EA1c.bin
chmod 777 c2950-i6q4l2-mz.121-19.EA1c.bin
 
# on the router, go into "en" mode.
# backup the startup-config file
copy nvram:startup-config tftp:
10.10.10.20   (the ip of the linux box)
startup-config (the file on the linux box)
 
# backup the IOS file
copy c2950-i6q4l2-mz.121-19.EA1c.bin tftp:
10.10.10.20   (the ip of the linux box)
c2950-i6q4l2-mz.121-19.EA1c.bin (the file on the linux box)  (note: "l" not "1")

Actions

This Discussion