×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

Redundancy Solution needed.

Unanswered Question
Nov 24th, 2008
User Badges:

The LAN consists of two Catalyst 6500 switches running HSRP over a dual L2 port channel.


Eigrp protocol is running between the core switches and WAN router.


What configuration solution can I apply to provide redundancy between the core switches and the WAN router.


!

6509-A


int fa0/1

description Router-A (E0/0)

switchport

switchport access vlan 100

switchport mode access


interface Vlan100

ip address 10.1.1.2 255.255.255.0

standby 100 ip 10.1.1.1

standby 100 priority 105

standby 100 preempt

standby 100 authentication C1sc0



router eigrp 250

network 10.0.0.0

no auto-summary

!



!

6509-B


int fa0/1

description Router-A (E0/1)

switchport

switchport access vlan 100

switchport mode access



interface Vlan100

ip address 10.1.1.3 255.255.255.0

standby 100 ip 10.1.1.1

standby 100 preempt

standby 100 authentication C1sc0



router eigrp 250

network 10.0.0.0

no auto-summary

!


!

Router-A


interface E0/0

ip address 10.1.1.253 255.255.255.0


interface E0/1

ip address



router eigrp 250

network 10.0.0.0

no auto-summary

!




Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joseph W. Doherty Mon, 11/24/2008 - 16:46
User Badges:
  • Super Bronze, 10000 points or more

"What configuration solution can I apply to provide redundancy between the core switches and the WAN router"


The single point of failure, I'm guessing you're concerned with, appears to be the single active Ethernet link on router-A.


The common solution would be routing. This could be done by placing the two router-A interfaces into different subnets, one connected to each separate 6500.


Other solutions might include: if you were running VSS on the 6500s, place the two Ethernet interfaces into a dual Etherchannel, one to each 6500; or perhaps bridging between the two Ethernet interfaces on router-A; or, if supported, load an Ethernet switch module into router-A and define a multiport VLAN (as you've done with the 6500s).


PS:

Of course, the WAN router itself will continue to be a single point of failure.

al.alexiev Mon, 11/24/2008 - 18:55
User Badges:

Well, there is no sense to use EIGRP or any other routing protocol between ONE router and ONE HSRP virtual switch! The only think you have to do is to put both Routers' interfaces in one BVI and to use IRB on L3 …

______________________

!Router-A

!

bridge irb

!

interface E0/0.100

encapsulation dot1Q 100

bridge-group 100

!

interface E0/1.100

encapsulation dot1Q 100

bridge-group 100

!

interface BVI100

ip address 10.1.1.253 255.255.255.0

no shutdown

!

bridge 100 protocol ieee

bridge 100 route ip

______________________


… and that's all.


If there are any other networks around this picture (another Router interface to outside etc.) EIGRP could be used, but you don't need it for now.

Actions

This Discussion