CUCM 6.1 and wireless 7921G "Locating Network Services"

Unanswered Question
Nov 25th, 2008

Hi all,

I have some 7921G phones on loan to test out. But i'm struggling to get them to connect to our Aironet1200 AP infrastructure. The phone just keeps "Locating Network Services" then evetually states "Connection failed"

We use PEAP on the APs with a standard SSID. Currently laptops can connect and get a DHCP address for data use. IP Communicator also works over the APs.

I've done some digging into the issue, and noticed in the official Cisco 7921 deployment guide that there is a "World Mode" that needs to be set on the APs...

(additional IOS commands):

Interface dot11radio X

world-mode dot11d country US both

We have the -W models of the 7921G phones, which the Cisco doco and a few forum posts suggest *do* need the above AP commands adding before an AP will allow registration.

Is it this simple...? Or am i missing something else?

I can scan for our APs on the phone and see various APs - but cant register the phone. 'World Mode' isnt set on our APs at present.

Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Alex Stuart Tue, 11/25/2008 - 21:34

Hi Andy,

Yes, you should enable world mode on the AP's, the phones wont connect otherwise, because you have the -W variant.

On a side note, you may need to look at the authentication method as well, I beleive, eap-fast is recommended for voice, as PEAP may introduce too much delay for voice.

Good Luck,

Alex

andy_vvc2 Fri, 11/28/2008 - 11:02

Thanks Alex!

Ive added the World mode config, but still get a failed connection on the wireless phone. Ive used the status scan on the phone to be sure it is trying to use the AP i am working on (top most listed AP in the scan, shown in red)

Here's the Dot11radio0 interface config. Perhaps some of our settings stop wireless phones from registering? I'm trying to use PEAP with username/password. Works on my laptop, not on the wireless phone...

interface Dot11Radio1

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache

!

encryption mode ciphers aes-ccm

!

broadcast-key change 300

!

!

ssid xxxxxxxxxxx

!

no dfs band block

speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0

channel dfs

station-role root

rts threshold 2312

world-mode dot11d country US indoor

l2-filter block-arp

no cdp enable

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

migilles Sun, 11/30/2008 - 19:15

Change to the following:

world-mode dot11d country US both

Not sure why you ordered -W phones when in the US, as you should order -A phones. But yes if you have -W model, then world mode MUST be enabled for the phone to operate.

The -W model is primarily for APAC, Australia and New Zealand.

Also didn't provide the ssid config, but should be something like the following, where the 7921G uses network eap.

dot11 ssid xxxxxxxxxxx

vlan X

authentication open eap eap_methods

authentication network-eap eap_methods

authentication key-management wpa version 2

We also recommend to only enable 12 mbps and higher and base the coverage on 24 mbps for dense deployments and to optimize for full capacity.

Actions

This Discussion