Pinging switches - bad delay

Unanswered Question
Nov 25th, 2008

Hi all

When pinging some switches on my lan, I sometimes see delay times up to 40ms, Is this ok, I am aware that ping is put the the back of the switch priority list, but evn so, I thought this is high.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
John Blakley Tue, 11/25/2008 - 07:06

Your arp entry will timeout if you aren't sending traffic to it all of time time. The ip address on L2 switches are used for management only, and if you aren't pinging them all of the time, the entry will timeout in your L3 switches or routers. When you ping and it can't find it in the arp table, it will broadcast for the mac address that owns the address and that's where you'll get your reply from. The default arp timeout is generally 4 hours.


glen.grant Tue, 11/25/2008 - 07:32

Switches will put a low priority on ping response behind more important processes it is running. This is not abnormally high , if you were getting like 200-300 ms then it might be something to look into . To test the switch itself you have to ping thru the switch to an attached device to get a ping response idea.

John Blakley Tue, 11/25/2008 - 07:35

Oh, I misunderstood the question. What Glen said is correct. I'm assuming that you are sending a constant ping, and your response times are 40ms? That's fine.

Thanks Glen! I had thought it was taking that long for the response to kick in. :-)



This Discussion