Cannot access devices on a vlan however the devices can access the switches

Answered Question
Nov 25th, 2008
User Badges:

This is probably a quick fix, however I am baffled. I have set up 2960 switches with a vlan of 10 for access and vlan 1 for trunking. I can ping and access all my switches from any other switch. I can access the switches from the device on an switch port however I cannot access the device from the switch. Is there something I am missing in the port configuration. Here are some of the configurations on the switch:


spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

switchport access vlan 10

switchport mode access

spanning-tree portfast


!

!

interface GigabitEthernet0/1

switchport access vlan 10



switchport mode trunk

!

interface GigabitEthernet0/2

switchport access vlan 10

switchport mode trunk

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan10

ip address xxx.xxx.53.219 255.255.254.0


502-NSW-1#show spann vlan 10


VLAN0010

Spanning tree enabled protocol ieee

Root ID Priority 32778

Address 001d.e68e.e000

Cost 19

Port 25 (GigabitEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)

Address 0024.1319.ed80

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300


Interface Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

Fa0/1 Desg FWD 19 128.1 Edge P2p

Gi0/1 Root FWD 19 128.25 Shr

Gi0/2 Desg FWD 4 128.26 P2p


If there is anything else to see, let me know


Correct Answer by glen.grant about 8 years 7 months ago

Where is the routing being done ? Sounds like the trunk is not working correctly.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
glen.grant Tue, 11/25/2008 - 13:19
User Badges:
  • Purple, 4500 points or more

Where is the routing being done ? Sounds like the trunk is not working correctly.

Mark Yeates Tue, 11/25/2008 - 13:19
User Badges:
  • Gold, 750 points or more

I would remove the "switchport access vlan 10" command from Gi0/2. If this does not work please post the full (sanitized) configs.



HTH,

Mark

John Blakley Tue, 11/25/2008 - 13:21
User Badges:
  • Purple, 4500 points or more

Do you mean that you can't ping the device that is connected to the switchport? Firewall enabled on the host?



John

Actions

This Discussion