no MWI suddenly for single user

Unanswered Question
Nov 25th, 2008

Funny enough, it should happen to the unity administrator, but suddenly (unity 4.05) I am not getting MWI's on my phone anymore. No changes were made... I believe it was working fine yesterday... I can call other people and after leaving them a message, they get immediate MWI. When I leave myself a message, no mwi. There are no errors in the event log to even indicate a problem... I have updated/refreshed my mwi (currently its showing an X as it always has for the extension).. I also tried to hard-code my extension in there, but still no mwi)... I tried to delete all mwi destinations, save and then re-add... still nothing. Is there any other place to look.. in sql table or anything for a switch that may be set... as mentioned, seems to work fine for other subscribers... just not me... this is unified messaging and I am getting the messages just fine, just not the mwi

thanks for any help!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
babatunde_sanda Tue, 11/25/2008 - 16:01

I once had a similar problem. Try this, it might help.

1.Restart this services in services.msc

* AvMsgstore monitor

* AvNotifier Mgr

Then go to the Unity tools depot

------- Switch integration manager

------- Integration Manager

----- Resynchronise now.

Rate if this helps.

ischarcm Tue, 11/25/2008 - 16:11

after doing a little more investigation, I ran a subscriber report... it doesn't even show that it attempted an MWI in the report.... so Im not sure if that would have anything to do with the msgstore monitor or avnotifier? Just wondering... I would hate to restart global services when I am the only known person with the problem... and the report showed my mailbox getting the messages, it just didn't show any attempt at all at dialing out the mwi.... if this new info helps at all??

ranpierce Tue, 11/25/2008 - 16:34

if the avnotifier does not get word from exchange of the new vm then it will not notify the pbx (callmanager) to dial the light on code.

In outlook you can see if the voicemail has the message class of IPM.Note.Voice.Unity

And the vm has to stay in the inbox. If you have rules for it to go to another folder, your mwi will not work.

Since it is only one person with the issue. My really hunch is this is the problem.


ischarcm Tue, 11/25/2008 - 16:42

Definitely no rule moving it to another folder as it is my mailbox we are talking about.

I will check the properties to see on the other thing, but again no changes were made to anything that I'm aware of...this worked fine up until yesterday or today when I noticed I wasn't getting mwi's anymore

ranpierce Tue, 11/25/2008 - 16:52

Also even though there is no MWI on your phone, can you check the vm you sent to yourself via the phone/TUI?


ischarcm Tue, 11/25/2008 - 16:58

good thought.. I had not actually tried that but just did... yes as soon as I log in via the tui it says that I have one new message and that is the test message I left myself.. so I can check via tui and hear the message

ischarcm Tue, 11/25/2008 - 16:57

hi ... yes the message is delivered to outlook, marked as a new message...

ranpierce Tue, 11/25/2008 - 17:20

OK I am sure you know this but everything is working so I would think that it is exchange and Unity not conversing correctly. from what you have said and tested all leads to this.

Either Excange is not sending notification of a new email or Unity is not recieving it.

I would try was suggested earlier. restart those services and resync if you can.

Stange that it is only one mailbox though.



This Discussion