How to configure cisco switches to connect alcatel phones and pcs?

Unanswered Question
Nov 26th, 2008

Hello,

one of our customers plans to connect alcatel ip phones "ip touch 4038" (with pcs connected to the phones) to cisco Cat4500 switches. Also normal pcs should be connected directly to the 4500.

So I think the phones would be connected with vlan trunk and the pcs with normal access port configuration.

To insure an easy switch administration we are looking for one (!) common switchport configuration which allows the connection of phones and also pcs. As far as I know with cisco phones we could use dtp so that the switchports dynamically uses trunk or access configuration depending on the connected device (phone or pc).

Does anybody know how we can fulfill this requirement with alcatel phones?

If there exist best practise documentation concerning ip phones (trunks, voice vlan etc.) it would also be fine if somebody could tell me the url.

Many thanks in advance,

Thorsten Steffen

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.5 (2 ratings)
Loading.
alig.norbert Wed, 11/26/2008 - 11:33

Hi Thorsten,

The IP-phone has to have a setting to configure the Voice VLAN-ID.

The voice traffic will then be dot1q-tagged (trunk). The connected PC will be transfered to the switch as native vlan.

Config for the switch-port:

interface fast0/10

switchport access vlan

switchport mode trunk

switchport native vlan

Greets,

Norbert

thorsten.steffen Wed, 11/26/2008 - 23:16

Hello Norbert,

as I wrote we also will connect pcs directly to the switch without phones between switch and pc.

Does you configuration

===

interface fast0/10

switchport access vlan

switchport mode trunk

switchport native vlan

===

also work when a pc (which does not support 802.1q) is directly attached to the switchport?

Best Regards,

Thorsten Steffen

alig.norbert Wed, 11/26/2008 - 23:34

Hi Thorsten,

When the pc is directly connected on the switch, it will use the switchport native vlan or switchport access vlan because it's not tagging (no dot1q).

Here a sample that we used for connecting a SNOM-SIP IP-Phone with a connected PC. This work as well for a pc directly connected (on the switch):

(vlan 16 is the pc vlan)

interface FastEthernet0/1

switchport access vlan 16

switchport trunk native vlan 16

switchport mode trunk

mls qos trust cos

spanning-tree portfast

Greets,

Norbert

thorsten.steffen Mon, 12/01/2008 - 02:29

Hello Norbert,

thank you for your explanation.

I tested the switchport configuration and it worked fine, both for a phone (with pc behind it) and for a pc. It worked also without the "switchport access vlan" command, I assume because for the switch it's always a trunk regardless what's connected.

So my test configuration looks like the following:

===

vlan 10

name pc-vlan

vlan 100

name voice-vlan

int fa0/1

switchport trunk native vlan 10

switchport trunk allowed vlan 10,100

swithport mode trunk

spanning-tree portfast

===

I also took some traces on the pc with wireshark in both setups and I found out some issues.

Setup 1: PC is connected at the phone

-> On the pc I get tagged broadcast traffic from the voice vlan. Perhaps my phone configuration is wrong; I checked the configuration but the only vlan parameters I can configure are

- activating vlans

- choose one vlan number

- activating the strict vlan option

So is it correct that the phone forwards voice vlan broadcasts to the pc port?

Setup 2: PC is connected directly at the switchport

-> Because the switchport is configured for tagging the voice vlan, all broadcast traffic (e.g. arp, stp) of the voice vlan is sent out of this port. So there is some unnecessary overhead now on this switchport. Did you already consider this issue?

Best Regards,

Thorsten Steffen

alig.norbert Mon, 12/01/2008 - 04:38

Hi Thorsten,

Actually, I've never traced the traffic on such a setup.

But I guess;

Setup 1; on the phone there can't be configured a vlan on the pc-port (phone works like a switch).

On setup 2; have you tried only the command "switchport trunk allowed vlan 100"?

Greets,

Norbert

Actions

This Discussion