EIGRP not forming adjacency

Unanswered Question
Nov 26th, 2008
User Badges:

Hi, I have an issue on an ATM router were the EIGRP adjacency are only forming in one direction.

The design is a hub and spoke, point to multipoint. The remote sites connect to the head end router via sub interfaces on the head end router. The issue I am seeing is that the remote site see the head end router as an EIGRP neighbour, however the head end router does not see the remote site as a neighbour, and as such no routing updates are passed.


The strange thing is, if I reboot the router, the EIGRP works fine until the Head end router's ATM drops



The config from the Head end router is



interface ATM0/0/0.30 multipoint

pvc 30/33

encapsulation aal5mux ppp Virtual-Template1

pvc 30/34

pvc 30/35 etc for all the sites


interface Virtual-Template1

ip unnumbered Loopback1

no peer default ip address

ppp authentication pap


Interface Loopback1

description ***Remote Sites WAN Interface***

ip address 192.168.227.1 255.255.255.0




router eigrp 1

redistribute connected

network 192.168.200.0

network 192.168.227.0

no auto-summary



The Config from the remote site ADSL router is



interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode ansi-dmt

!

interface ATM0.1 point-to-point

description **To Augres**

no snmp trap link-status

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface ATM0.2 point-to-point

no snmp trap link-status

pvc 0/39

encapsulation aal5mux ppp dialer

dialer pool-member 2

interface Vlan1

ip address 192.168.25.1 255.255.255.0

hold-queue 100 out

!

interface Dialer1

bandwidth 512

ip unnumbered Loopback1

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxxxx password xxxx

!

!

router eigrp 1

redistribute connected

network 192.168.25.0

network 192.168.227.0

network 192.168.229.10 0.0.0.0

auto-summary

eigrp stub connected summary




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 11/26/2008 - 04:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Richard,

the remote site is point-to-point while the hub has a multipoint interface


I think for each pvc you need on the hub


pvc 30/34

protocol ip remote-side-loopback broadcast


this allow the router to map also EIGRP multicast hellos to the neighbors(s)


Hope to help

Giuseppe


richard.jackson Wed, 11/26/2008 - 07:48
User Badges:

Hi Giuseppe,


Thanks for the reply. Though it hasn't resolved the issue it has pointed me in the right direction to the underlying fault.

If I multicast ping from the head end router to the remote site, I get a reply back from all the remote sites. However if I carry out the same from the remote site I do not set any replies!.

Any other thoughts?


Regards

Giuseppe Larosa Wed, 11/26/2008 - 08:14
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Richard,

another possible option to get rid of multicast hellos is to use the neighbor command so that unicast messages are exchanged.

This is also a way to detect if the problem is with the multicast nature of Hellos


under router eigrp add


on hub

a neighbor ip-address for each remote


on remote

a single neighbor statement for hub


Hope to help

Giuseppe


Actions

This Discussion