Uninstall and re-install on a CW IPM

Unanswered Question
Nov 26th, 2008

Possible for me to do uninstall and re-installation on a specific module only? Eg. CW IPM? Any guide on it?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 11/27/2008 - 09:36

Run the LMS uninstall program, then select only IPM from the list. When finished, run the Setup program from the DVD, and choose to only reinstall IPM.

jeeyishyuan Thu, 11/27/2008 - 09:43

But it seems like I am not able to re-install IPM aft the uninstallation.

Setup wizard stopped to proceed as it prompted that I have am trying to install earlier version of CM, RME, DFM and other applications. This is because I have previously ran the update and install patch files downloaded from Cisco.com.

I have tried to search for any separate module .exe files to run in the installation folder but it seems like only autorun.exe is in the folder.

As such, I tried to do a restore from my previous backup (with IPM installed). However, IPM is not restored as it is no longer installed on CW.

Joe Clarke Thu, 11/27/2008 - 09:50

This is due to bug CSCsj94584. There workaround is tricky, so it is best to have a TAC service request open to make sure you're modifying the right files:

1. Modify the .info files for the patched modules under NMSROOT/setup and set the value of PATCHVER in these files to their original value of 0.

2. Install the new application on CiscoWorks Server.

3. Reset the values of PATCHVER to their patched versions after the installation is complete.

jeeyishyuan Thu, 11/27/2008 - 09:59

So I am supposed to do this after my uninstallation or before that?

Joe Clarke Thu, 11/27/2008 - 10:04

The .info files need to be modified after the uninstallation, but before the reinstallation. The modifications will trick the installer into thinking an unpatched LMS 3.0 is installed, and will allow IPM to be reinstalled.

Actions

This Discussion