Cisco 7507 Router High CPU utilization-IP RIB Updates Max Utilized Process

Unanswered Question
Nov 26th, 2008

HI All,

We have Cisco 7507 router with RSP 16 with 512MB memory module. Running EBGP in the router.

We are facing the HIGH CPU utilization in the router when we enable the BGP peer with the SP to receive the Routing table. Observerd that IP RIB UPDATES process is taking the maximum CPU utilization.

We are running the 12.4.21 IOS Image in the Router.

Can anyone help us in this case?

Thanks & Regards,

Vishnu

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 11/27/2008 - 06:45

Hello Vishnu,

is this high cpu usage steady of happen only on the first minutes of eBGP session up during prefixes loading ?

If steady, have you enabled any additional feature like next-hop tracking, BGP dumpening or others ?

If after ten minutes the cpu load start to low it is heavy to startup.

Hope to help

Giuseppe

vishnu.vr Thu, 11/27/2008 - 20:13

Hi Giuseppe,

Thanks for your reply.

We observed for more than 30 mins of eBGP session up during prefexes loading but still we are seeing the Up and down high CPU utilization. like 100% --- 40% ----0% ---100%.

We didn't enable any additional features.

As per customer they will be receiving the 1.30lakhs routes from SP.

This RSP is having 512MB memory module. i.e. 2*256 MB modules.

Find the below configuration of bgp.

!

interface Loopback2

description ##VSNL ##

bandwidth 8192

ip address 196.12.34.243 255.255.255.255

!

router bgp 7633

no synchronization

bgp log-neighbor-changes

network 196.12.33.0

network 196.12.34.0

neighbor 202.54.120.20 remote-as 4755

neighbor 202.54.120.20 password 7

neighbor 202.54.120.20 ebgp-multihop 50

neighbor 202.54.120.20 soft-reconfiguration inbound

neighbor 203.199.191.179 remote-as 4755

neighbor 203.199.191.179 description New VSNL BGP

neighbor 203.199.191.179 ebgp-multihop 5

neighbor 203.199.191.179 update-source Loopback2

neighbor 203.199.191.179 send-community

neighbor 203.199.191.179 soft-reconfiguration inbound

neighbor 203.199.191.179 route-map vsnl-in in

neighbor 203.199.191.179 route-map VSNL4E1OLD out

maximum-paths 4

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 203.199.191.179

ip route 0.0.0.0 0.0.0.0 202.54.120.20

ip route 196.12.33.0 255.255.255.0 Null0

ip route 196.12.34.0 255.255.255.0 Null0

Do you have any idea is this exsiting RSP 16 with 512MB memory will support 1.30lakhs routes?

Thanks & Regards,

Vishnu

Giuseppe Larosa Fri, 11/28/2008 - 00:05

Hello Vishnu,

I see possible issues for memory usage coming from:

maximum-paths 4

both eBGP speakers are sending full BGP tables ?

how are configured the route-map filters vsnl-in and VSNL4E1OLD

how many prefixes after loading are in the table use

sh ip bgp summary

1.30lakhs routes ?? I don't understand this unit of measure

nowdays a full table is in the range of 260,000 routes.

Are you receiving a great partial table ?

Hope to help

Giuseppe

vishnu.vr Fri, 11/28/2008 - 02:38

Hi Giuseppe,

Its 130,000 routes. not 1.30 Lakhs Routes.

Customer is advertising his routes through one ebgp session (x.x.191.179) and receiving the other routing table from Other eBGP session (x.x.120.20).

!

ip prefix-list 32nw seq 5 permit X.X.32.0/24

ip prefix-list 33nw seq 5 permit X.X.33.0/24

!

route-map VSNL4E1OLD permit 10

match ip address prefix-list 32NW 33NW

!

route-map VSNL4E1OLD permit 20

match ip address prefix-list "Respective Prefix-list name"

set as-path prepend 7633 7633

!

route-map VSNL4E1OLD permit 40

match ip address prefix-list "Respective Prefix-list name"

set as-path prepend 7633 7633 7633 7633 7633

!

route-map vsnl-in permit 10

set local-preference 100

Thanks & Regards,

Vishnu

vishnu.vr Sat, 11/29/2008 - 22:24

HI Giuseppe,

Yesterday we troubleshooted the CPU hike issue and its got resolved.

We suspected Flapping BGP Routes (Recursive Routing Failure)in the router.

After receiving the large routing table we checked for recursive routes and found the recursive routes in the routing table.

SH IP ROUTE | include 00:00

done some changes in the routing part and found CPU utilization came down after some time and stable now.

Thanks & Regards,

Vishnu

Giuseppe Larosa Sun, 11/30/2008 - 04:25

Hello Vishnu,

good news to read that you solved the issue and that now the router CPU is stable at lower levels.

I guess yu have you added / modified the BGP dampening policy to get rid of fast changing routes ?

Best Regards

Giuseppe

vishnu.vr Sun, 11/30/2008 - 06:44

Hi Giuseppe,

Yes, now router CPU is stable at lower levels.

We done small changes in the routing part (Removing unnecessary default route, Adding respective Static routes)in our router.

Thanks for your support Mr. Giuseppe.

Thanks & Regards,

Vishnu

Actions

This Discussion