LWAPs stuck in downloading state after WLC upgrade

Unanswered Question
Nov 27th, 2008

So I upgraded our WLC from version to Out of 98 LWAPs 8 didn't take the upgrade pushed out by the WLC. They seem to be stuck in a "downloading" operational status.

When I tried to add another LWAP from my workstation it seems to constantly try to upgrade but just ends up rebooting in a never ending cycle. The following is a capture:

*Mar 1 00:00:05.152: soap_prepare_new_image_crash: mini ios flash:/c1130-rcvk9w8-mx/c1130-rcvk9w8-mx

*Mar 1 00:00:05.153: set boothlpr to mini ios

*Mar 1 00:00:05.438: %SOAP_FIPS-2-SELF_TEST_IOS_SUCCESS: IOS crypto FIPS self test passed

*Mar 1 00:00:06.715: %SOAP_FIPS-2-SELF_TEST_RAD_SUCCESS: RADIO crypto FIPS self test passed on interface Dot11Radio 0

*Mar 1 00:00:07.068: %LINK-5-CHANGED: Interface Dot11Radio1, changed state to reset

*Mar 1 00:00:08.041: %SOAP_FIPS-2-SELF_TEST_RAD_SUCCESS: RADIO crypto FIPS self test passed on interface Dot11Radio 1

*Mar 1 00:00:09.143: %SYS-6-LOGGERSTART: Logger process started

*Mar 1 00:00:09.183: %SYS-5-RESTART: System restarted --

Cisco IOS Software, C1130 Software (C1130-K9W8-M), Version 12.3(11)JX, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Mon 05-Jun-06 16:41 by pwade

*Mar 1 00:00:09.184: %SNMP-5-COLDSTART: SNMP agent on host ap is undergoing a cold start

*Mar 1 00:00:10.080: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to up

*Mar 1 00:00:11.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to up

*Mar 1 00:00:22.639: %CDP_PD-4-POWER_OK: Full power - NEGOTIATED inline power source

*Mar 1 00:00:28.198: %LWAPP-5-CHANGED: LWAPP changed state to DISCOVERY

*Mar 1 00:00:40.592: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0 assigned DHCP address, mask, hostname AP001b.d40b.107a

Translating "CISCO-LWAPP-CONTROLLER.nation.radix"...domain server (

*Mar 1 00:00:49.685: LWAPP_CLIENT_ERROR: lwapp_name_lookup - Could Not resolve CISCO-LWAPP-CONTROLLER.nation.radix

examining image...

extracting info (286 bytes)

Image info:

Version Suffix: k9w8-.123-11.JX

Image Name: c1130-k9w8-mx.123-11.JX

Version Directory: c1130-k9w8-mx.123-11.JX

Ios Image Size: 3072512

Total Image Size: 3072512


Image Family: C1130

Wireless Switch Management Version:

Extracting files...

c1130-k9w8-mx.123-11.JX/ (directory) 0 (bytes)

extracting c1130-k9w8-mx.123-11.JX/info (286 bytes)

extracting c1130-k9w8-mx

*Mar 1 00:00:59.710: %LWAPP-5-CHANGED: LWAPP changed state to JOIN

*Mar 1 00:00:59.710: %LINK-5-CHANGED: Interface Dot11Rad.123-11.JX/6701.img (131328 bytes)io0, changed state to administratively down

*Mar 1 00:00:59.711: %LINK-5-CHANGED: Interface Dot11Radio1, changed state to administratively down

*Nov 28 03:44:00.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to down

*Nov 28 03:44:00.887: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio1, changed state to down

*Nov 28 03:44:01.153: %LWAPP-5-CHANGED: LWAPP changed state to IMAGE

extracting c1130-k9w8-mx.123-11.JX/c1130-k9w8-mx.123-11.JX (2800592 bytes)

extracting c1130-k9w8-mx.123-11.JX/7101.img (131328 bytes)

extracting info.ver (286 bytes)

Deleting existing version...

Deleting flash:/c1130-k9w8-mx.123-11.JX...done.

New software image installed in flash:/c1130-k9w8-mx.123-11.JX

Configuring system to use new image...done.archive download: takes 53 seconds

*Nov 28 03:44:54.879: image upgrade successfully, system is now reloading

*Nov 28 03:44:54.917: %SYS-5-RELOAD: Reload requested by lwapp image download proc. Reload Reason: NEW IMAGE DOWNLOAD.

*Nov 28 03:44:54.917: %LWAPP-5-CHANGED: LWAPP changed state to DOWN

Then it reboots and repeats the process.

I have read through other conversations similar to this but have found no solution. Does anyone have any ideas?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
brodierad Sun, 11/30/2008 - 16:05

I worked around it anyway. I just disassociated the affected LWAPs from the WLCs by removing their MAC addresses. They upgraded when I added back the MAC addresses one at a time.

brodierad Mon, 12/01/2008 - 15:21

No I didn't. Some of the LWAPs were interstate so I was trying to find a remote solution first.

steven.vandyk Tue, 09/28/2010 - 01:19

Did you find a solution? I have the same problem.

Edit: Seems my AP keeps switches between 2 controllers with different software versions. However only 1 is in the DHCP option.


This Discussion



Trending Topics - Security & Network