CVP Queue music issue

Answered Question

I have ipcc 7.1 with cvp 3.1(h323) with gatekeeper, my issue with the Queue music which is less than 500k some time it doesnot play it took 16 day playing fine and suddenly it stops playing and I do rename the file every time I got this error after that it works fine for a while, when I checked the application server log it says(ERROR:Media Fetch Error for url=http://10.0.232.15/en-us/app/zainsd/Queue_Mu.wav), please advice

The gateway settings are OK.


FYI, I set "ivr prompt memory 16384 files 1000".


If you have a lot of RAM in the gateway you can raise the memory pool. We have a lot of RAM and have the HTTP memory max'd out to 50000.


The "memory file" setting of 500 means a prompt bigger than 500 kbytes (approx 50 sec) will not be cached. No problem here.


Now why do you have no lifetime set on the web server?


This means that whenever a prompt is required to be played, the router checks the cache to see if it's stale. In your case, the prompt will always be stale and will be fetched from the HTTP server.


When multiple calls are in action at the one time (under load), each is requesting to fetch the file from the HTTP server, and since this is quite a big file, you get time-outs.


If you set content expiration to say 1 day, then the first call for the day fetches the file since it is stale, plays the prompt and then puts it into the HTTP client cache.


During the rest of the day, requests for that prompt will check the age of the file against the lifetime (1 day) and will not need to fetch the file - it will be played out of memory.


Poor caching can drop performance by 30% - you are seeing the effects of that.


You can read the Cisco document "IVR HTTP Client White Paper" for more details.


Regards,

Geoff



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
david.macias Sun, 11/30/2008 - 08:16
User Badges:
  • Blue, 1500 points or more

Does it stop working during high call volume?


david

david.macias Tue, 12/02/2008 - 05:09
User Badges:
  • Blue, 1500 points or more

Any reason as to why you have your content expiration disabled in IIS? Usually 12 to 24 hours is a good rule of thumb.


david

Correct Answer

The gateway settings are OK.


FYI, I set "ivr prompt memory 16384 files 1000".


If you have a lot of RAM in the gateway you can raise the memory pool. We have a lot of RAM and have the HTTP memory max'd out to 50000.


The "memory file" setting of 500 means a prompt bigger than 500 kbytes (approx 50 sec) will not be cached. No problem here.


Now why do you have no lifetime set on the web server?


This means that whenever a prompt is required to be played, the router checks the cache to see if it's stale. In your case, the prompt will always be stale and will be fetched from the HTTP server.


When multiple calls are in action at the one time (under load), each is requesting to fetch the file from the HTTP server, and since this is quite a big file, you get time-outs.


If you set content expiration to say 1 day, then the first call for the day fetches the file since it is stale, plays the prompt and then puts it into the HTTP client cache.


During the rest of the day, requests for that prompt will check the age of the file against the lifetime (1 day) and will not need to fetch the file - it will be played out of memory.


Poor caching can drop performance by 30% - you are seeing the effects of that.


You can read the Cisco document "IVR HTTP Client White Paper" for more details.


Regards,

Geoff



Actions

This Discussion