duplicate name errror

Unanswered Question
Dec 1st, 2008
User Badges:

we have an ASA5505 running 8.03 setup with two interfaces inside/outside. There is a SQL server on the inside leg with a static NAT to the outside so it can communicate to the rest of the company's internal network. This setup has been working for a month or two, but recently they had to reboot the server for maintenance. When the server came back it reported a duplicate name error and went into offline mode. support at the site was finally able to get their server up by first shutting down the firewall and then bringing the sever up. The server comes online as normal then the firewall was turned on and everything appears to be working fine. However this appears to happen every time that you have to reboot the server.


Key firewall statements:

interface Vlan100

description *** plant Network ***

nameif inside

security-level 0

ip address x.x.0.1 255.255.0.0

!

interface Vlan200

description *** company internal Network ***

nameif outside

security-level 100

ip address x.x.x.8 255.255.255.128

!

interface Ethernet0/0

switchport access vlan 100

!

interface Ethernet0/1

switchport access vlan 200

!

static (inside,outside) x.x.x.14 x.x.x.50 netmask 255.255.255.255 dns

!

dhcpd auto_config inside

!

so when the asa's outside leg is the company's internal inter-network interface which provide's the inside leg (site network) inter-network interface DNS/WINS, could the problem be with DNS/WINS and not the ASA?


any suggestions would be helpful


thanks, Kevin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Mon, 12/01/2008 - 13:26
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kevin


I haven't used the "dns" option at the end of the static statement before. But what occured was that if you need to reboot the ASA firewall before it works again it looks like the ASA is caching the record somehow.


Have you tried clearing the specific xlate for the SQL server rather than reloading the ASA firewall.


Jon

Actions

This Discussion